0

I am running Ubuntu 18.04 desktop in a Virtual Box virtual machine. It has been working fine except just recently I came back to the machine and tried to enter my password after it timed out after a period of no access.

Instead of allowing me to enter my password it kept saying "Authentication error". It might have been "Authorization error"...I can't remember.

With no way to log in I rebooted the virtual machine. Except now it always drops straight into a tty terminal and never shows the gui interface.

What has happened here? And, more importantly, how can I get the desktop back? I really don't want to build a new VM and reinstall everything again.

The plot thickens...

Since originally posting I rebuilt a VM from scratch installing Ubuntu 18.04.2, VSCode, MySQL, Python3 VirtualEnv, and Django. It was working fine when I shut it down before leaving work at the end of the day. When I came in this morning and started it up I had the same problem...it boots into a tty and the GUI is nowhere to be seen.

  • Can you login in the tty? If so try startx and take note of error messages. – GabrielaGarcia Jul 10 at 14:32
  • When I run startx the VM screen size changes and I get a big black X as a cursor, as well as a terminal prompt in the top left. Nothing else happens. When I exit from the terminal it switches back to my tty terminal with no apparent error messages resulting from the startx run. – M. Webb Jul 10 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.