0

I have checked other posts about randomly rotating screens, and screens that rotate after sleep. I have tried the following to no avail:

1. Lock Screen Rotation

enter image description here

Problem persists.

2. Disable Gnome Orientation Plugin

$ gsettings set org.gnome.settings-daemon.plugins.orientation active false

Problem persists.

3. Disable/Uninstall iio-sensor-proxy

$ sudo systemctl stop iio-sensor-proxy.service
$ sudo systemctl disable iio-sensor-proxy.service

$ sudo apt-get remove iio-sensor-proxy

Problem persists.

Every time I close the lid, laptop awakes sideways and I have to run:

$ xrandr -o normal

Is there a bug somewhere? Have I missed something?

How can I make xrandr -o normal run every time the laptop wakes from suspend? Maybe a hackish solution, but it might work right?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.