1

Works fine in Windows 7 I just put in the dvd and it plays. I've downloaded VLC for Ubuntu 11.10 and tried playing both the individual vob files (didn't work) and the root directory on the dvd (also didn't work). I've read something about mounting the dvd as an iso? Could someone talk me through getting this to work? For what it's worth they're legit dvds, not copies or anything, so I'm surprised I can't get it to work. Thanks in anticipation!

  • the codec DVD's use is patented, that's why it's not working – Janus Troelsen Mar 24 '12 at 20:40
4

https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

| improve this answer | |
1

Install Medibuntu using command Line in Ubuntu 9.10 + ( Including Ubuntu 12.04 LTS Precise Pangolin):

Open terminal and enter the folowing command :

sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

Enable DVD support:

To play encrypted DVDs, the libdvdcss2 package is essential. libdvdcss is a simple library designed for accessing DVDs like a block device without having to bother about the decryption.

If you already added Medibuntu repositories above, you can Install from software center or using the terminal by entering the following command:

sudo apt-get install libdvdcss2 && sudo /usr/share/doc/libdvdread4/./install-css.sh

source

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.