I'm trying to install KLatexFormula and it's cmake script is giving the error that it cant find the package config files Qt5DesignerConfig.cmake and qt5designer-config.cmake.

Cmake asked me to add the prefix of Qt5Designer to CMAKE_PREFIX_PATH. I found the path to Qt5Designer with a quick

apt-files search Qt5Designer

The file I was looking for showed up under the path


under qttools5-dev package. I believe this is the correct spot, so I added the prefix path with

export QT_CMAKE_PREFIX_PATH="/usr/lib/x86_64-linux-gnu/cmake"

and the path shows up if I check the command


However, building the cmake file again gave me the same missing packages. In the process of trying to work out what was wrong I went

cd /usr/lib/x86_64-linux-gnu/cmake

At this point I saw that there was no Qt5Designer entry in this folder. My qttools5-dev is completely up to date. Anyone know how I can fix it?

And I have tried this already and get the same search results as that answer.


2 Answers 2


To anyone else having the issue with qttools5-dev-tools not installing Qt Designer stuff try

sudo apt install qttools5-dev

instead (note there is no -tools at the end).

I was also lacking qt5svg and qt5x11extras, and these were solved with

sudo apt install libqt5svg5-dev


sudo apt install libqt5x11extras5-dev


  • Working for build from source ksnip 1.8.0 to solve this: "If "Qt5Svg" provides a separate development package or SDK, be sure it has been installed." Jan 13, 2021 at 11:26

Anyone who has this issue you would need to install the following:

apt install libqt5charts5-dev
install qtbase5-dev libqt5x11extras5-dev libqt5svg5-dev qtdeclarative5-dev libqt5charts5-dev libmuparser-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.