Here is my problem. I have a 2-years old LeNovo Thinkpad 13 (Intel Core i5), with Ubuntu on it. The battery does not want to charge anymore: when I plug the AC, I can use the laptop perfectly, and in the menu this is written "charging"... but the percentage does not move (6% at the moment).

I thought that was a problem of my former battery so I bought a new one. Same pb.

I have two different chargers so the pb does not come from it.

I tried the "power reset" thing (as explained here in Fix 2:https://www.drivereasy.com/knowledge/solved-plugged-in-not-charging-in-lenovo-laptop/), and I also tried to "Disable built-in battery" in the BIOS (as explained here Battery not charging but detected) with no success.

Now I don't have any idea, except using only my laptop at home.

Any answer would be great!

Thanks a lot.


  • actually my father having gone throught the same problem, realized that old batteries are a nightmare and you are likely to be shipped with one that already broke down with the years or is just barely the wrong specs (not by same manufacturer). can we rules these things out 100% first? in anycase there is no way ubuntu could be responsible for this.
    – tatsu
    Jul 9, 2019 at 13:52
  • The "old" battery (in fact only 2 years old) works exactly the same as the new one. So I guess the probability that the 2 batteries have the exact same problem is not very big...
    – Clem.
    Jul 9, 2019 at 15:42
  • 1
    or it's not the battery, it's the PCB/power supply with a short circuit or cut leading to no charge arriving at the battery. that can happen too.
    – tatsu
    Jul 9, 2019 at 16:11
  • Well, today was surprising: I found my laptop with only 1% battery left, I plugged it in and, miracle, it worked perfectly - until being charged at 100%. Then I removed the AC and the battery went down to a few percent. I plugged it in a few minutes ago, and now I still have the exact same problem: the battery is blocked at 6% but doesn't charge (this is written "estimating..." with no time). I don't see any solution except going to (another) repair shop now.
    – Clem.
    Jul 11, 2019 at 20:18
  • I'm sure of it now: it's the PCB having a short circuit at the area where it brings charge to the battery. a new battery won't fix it. both of those you have probbaby work.
    – tatsu
    Jul 12, 2019 at 7:38


You must log in to answer this question.

Browse other questions tagged .