When I try to install/run ubuntu from a liveCD, it just hangs on this screen...


Any ideas?

I've unplugged all my usb devices other than my death adder mouse and g15 keyboard, tried 32bit and 64bit 11.10 but both do the same thing.

Ran the memory test on the ubuntu install CD and it was fine.


pc specs.. Asus P5Q motherboard Q6700 cpu 4gig dominator 1066mhz corsair 1tb HDD Asus 560ti graphics card

edit : after unplugging all my usb devices (putting a new keyboard in) and disabling firewire on my motherboard in the bios, I get the image below...


  • 1
    What video chip do you use? Did you MD5 test the ISO you downloaded? Did you burn the CD as slowly as possible? – ActionParsnip Mar 24 '12 at 22:14
  • 1
    I use an asus 560ti. I didn't md5 the download, but i tried two different ISO's. I will try burning a third CD. – david99world Mar 25 '12 at 10:50
  • I made it on 5th CD. =P – H_7 Mar 25 '12 at 14:36

Once you burn the .iso to the CD/DVD, be sure to check 'Verify disc after burning' / 'Verify disc' check box on your burn application. This is rareley useful, but could be the cause of the problem.


I am just guessing but it looks like a bad RAM chip on the video card. If I were you I would figure out how to scan the ram on the video card OR figure out how to install in VGA mode (maybe with a boot arg to the installer?).


Turned out it was my 560ti that it didn't like. Booted with nomodeset and it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.