2

I am on Ubuntu 19.04, GNOME Shell 3.32.1, on a Lenovo laptop. I have installed libinput-tools and some touchpad gestures work fine. However, there is a gesture that I cannot find in the libinput configuration file and I am not sure if it's from libinput (I also purged libinput and it still worked so I am almost sure it is not from libinput). When I scroll horizontal with two fingers, it controls the volume (scrolling right increases it while scrolling left decreases it).

It is very annoying and I am trying to find out how can I disable it. Any suggestions would be welcome!

Edit: synclient output:

Parameter settings:
    LeftEdge                = 1574
    RightEdge               = 5368
    TopEdge                 = 1350
    BottomEdge              = 4504
    FingerLow               = 25
    FingerHigh              = 30
    MaxTapTime              = 180
    MaxTapMove              = 252
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    EmulateMidButtonTime    = 0
    EmulateTwoFingerMinZ    = 282
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = -114
    HorizScrollDelta        = -114
    VertEdgeScroll          = 0
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 1
    HorizTwoFingerScroll    = 1
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0348797
    TouchpadOff             = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 3
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 1
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 0
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 28
    VertHysteresis          = 28
    ClickPad                = 1
    RightButtonAreaLeft     = 3471
    RightButtonAreaRight    = 0
    RightButtonAreaTop      = 4100
    RightButtonAreaBottom   = 0
    MiddleButtonAreaLeft    = 0
    MiddleButtonAreaRight   = 0
    MiddleButtonAreaTop     = 0
    MiddleButtonAreaBottom  = 0

Edit2: gsettings list-recursively org.gnome.settings-daemon.plugins | grep --ignore-case volume output:

org.gnome.settings-daemon.plugins.media-keys volume-up 'XF86AudioRaiseVolume'
org.gnome.settings-daemon.plugins.media-keys volume-mute 'XF86AudioMute'
org.gnome.settings-daemon.plugins.media-keys volume-down 'XF86AudioLowerVolume'
9
  • I do not remember. I have been using libinput-tools for a while. Again, even when I remove the package I still have that gesture, so it does not seem to be related.
    – m0ur
    Jul 9, 2019 at 9:05
  • 1
    Yes, just tried that. Also, this is the repository of libinput that I am using.
    – m0ur
    Jul 9, 2019 at 9:11
  • alright, here : github.com/bulletmark/libinput-gestures/issues/… is where you can ask for help specific to that library. but since even after uninstall and rebbot your gestures still work I'm starting to think this library is not responsible.
    – tatsu
    Jul 9, 2019 at 9:14
  • Yes, I know, that's what I am saying :)
    – m0ur
    Jul 9, 2019 at 9:15
  • I don't think I have installed anything else related to the touchpad.
    – m0ur
    Jul 9, 2019 at 9:45

0

You must log in to answer this question.

Browse other questions tagged .