9

I've just recently switched to Ubuntu 19.04 and I am now getting dull colors in terminal but only outside of programs:

dull colors

In comparison you can see the vivid colors I am used to when I use ranger:

vivid colors with ranger

I have changed my prompt to:

PS1='\[\e[01;32m\]\u ∈  \h\[\e[m\] \[\e[01;34m\]\w ⊢ \[\e[m\] '

The colors appear this way in gnome-terminal and terminator.

Thanks for any help fixing this!

14

GNOME Terminal 3.32 (debuted in Ubuntu 19.04) changed the default of the "Show bold text in bright colors" option to disabled. As another answer nicely shows you, one possible fix is to revert that setting.

However, this change was intentional and is going to stay the default. There's a legacy confusion about the meaning of the 1 (or 01) in the escape sequence you showed. The standard (ECMA-48 § 8.3.117) says "bold or increased intensity", so it's not clearly defined, and both the old (bold and bright) and the new (bold only) behaviors are conformant. There exist now other means of picking any of 16 million colors, yet no unambiguous option for "bold". Our aim is to separate these two, and make 1 stand for "bold" only.

\e[01;32m in your prompt used to switch to green text (32) and make it both brighter and bolder (01). On the other hand, this approach doesn't allow you to combine the darker shade with bold typeface. With gnome-terminal's new behavior this limitation isn't there anymore.

Numbers 90–97 can be used for the bright colors as foreground ones, and 100–107 as background ones. These switch to the brighter counterpart without making them bold.

So here's my recommendation that points towards the future, with the clear separation of these two orthogonal properties.

Leave the checkbox at its new default state, disabled. Decide what colors and attributes you want to have in your prompt, and modify it accordingly. If you want to have a bright color, replace 32 with 92, 34 with 94 etc. With the new behavior, this influences the brightness but not the boldness. Independently from this, if you want a bold typeface, keep the 01, if not, remove it. With the new behavior, this influences the boldness but not the brightness.

5

The settings for gnome-terminal are in:

[Terminal Menu] -> [Preferences] -> [Profile Name]

I think the setting you're looking for is:

"Show bold text in bright colors"

gnome-terminal preferences window

As you can see, most of these settings are now inherited from the system theme, so, other than that setting, if you want consistency across all your compliant terminals, then I'd change the settings in the system theme.

  • There's no "Show bold text in bright colors" in the system theme, it's not inherited from there. This is a configuration option that only exists in the terminal. – egmont Jul 9 at 11:26
  • @egmont Yes, that's correct. I was just mentioning in passing that all the other colour options are inherited from the system theme. The "Show bold text in bright colors" is the first part of the answer. Your answer gives the backstory which is very interesting! – tudor Jul 9 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.