1

Installed nextcloud on Raspi with snap. Now I am stuck with editing the config.php file. Tried:

chomd 775 config.php

also tried

sudo chmod 775 config.php

It comes up:"changing permissions of 'config.php': Read-only file system"

Complete Path is: /snap/nextcloud/current/htdocs/config/config.php Has anybody a tip how to change it into write permission? Thank you!

  • 1
    A read-only file system usually means something has gone wrong, and you need to fsck (file system check). It could also be you've mounted it that way, but if it's your /, I'd suspect a fsck. I'd remove the memory card & use a another device (probably a pc) to fsck the memory-card. – guiverc Jul 8 '19 at 8:59
  • thank you! will try that out. – KatKat Jul 8 '19 at 11:55
0

Snaps are mounted as read-only filesystems. Therefore none of the files under ´/snap/nextcloud/´ can be edited. Each snap does have a writable directory under ´/var/snap//current´. You might check there for the config.php.

However, snaps also have a native configuration system which nextcloud could be using. Try running ´snap get nextcloud´. If you see a list of configs, you probably want to set them there

| improve this answer | |
  • Ah thank you! This one worked perfectly fine!!! – KatKat Jul 19 '19 at 17:45
0

Installing snap core worked for me.

sudo snap install core
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.