0

Distro up to date and trying to launch totem from the command line results in the following:

totem: ../src/gallium/drivers/nouveau/nouveau_vp3_video.c:91: nouveau_vp3_video_buffer_create: Assertion `templat->interlaced' failed.
Aborted (core dumped)

Video card from lspci is as follows:

01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [NVS 310] (rev a1)

Running on Xorg also.

Below is the relevant information from dmesg:

[    2.911111] fb: switching to nouveaufb from VESA VGA
[    2.911418] nouveau 0000:01:00.0: NVIDIA GF119 (0d93d0a1)
[    3.062868] nouveau 0000:01:00.0: bios: version 75.19.85.00.01
[    3.063749] nouveau 0000:01:00.0: fb: 512 MiB DDR3
[    4.368526] nouveau 0000:01:00.0: DRM: VRAM: 512 MiB
[    4.368526] nouveau 0000:01:00.0: DRM: GART: 1048576 MiB
[    4.368529] nouveau 0000:01:00.0: DRM: TMDS table version 2.0
[    4.368530] nouveau 0000:01:00.0: DRM: DCB version 4.0
[    4.368532] nouveau 0000:01:00.0: DRM: DCB outp 00: 028003a6 0f220010
[    4.368533] nouveau 0000:01:00.0: DRM: DCB outp 01: 02000362 00020010
[    4.368534] nouveau 0000:01:00.0: DRM: DCB outp 02: 048113b6 0f220010
[    4.368535] nouveau 0000:01:00.0: DRM: DCB outp 03: 04011372 00020010
[    4.368536] nouveau 0000:01:00.0: DRM: DCB conn 00: 00410146
[    4.368537] nouveau 0000:01:00.0: DRM: DCB conn 01: 00820246
[    4.436282] nouveau 0000:01:00.0: DRM: MM: using COPY0 for buffer copies
[    4.636966] nouveau 0000:01:00.0: DRM: allocated 1920x1200 fb: 0x60000, bo         (ptrval)
[    4.638486] fbcon: nouveaufb (fb0) is primary device
[    4.638592] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[    4.676010] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 0

I've come across a few blurbs about nouveau possibly not supporting interlaced video -- seems related to the failed assertion -- but nothing in combination with totem issues.

Any suggestions? Better off filing a bug report with totem and/or nouveau?

I'm not interested in running the proprietary NVIDIA driver as it results in quite odd screen flickering and video garbage displayed at startup and reboot that is very janky. Sometimes during reboot is just hangs as well. Additionally, I suffered from other intermittent display issues with the proprietary driver that drove me back to the nouveau driver some time ago. The nouveau driver "just works" quite well for my general use purposes -- until now that is.

  • I figured it out. Some time ago I followed the nouveau instructions to enable video acceleration at the following link. Once I renamed the directory that contained the firmware -- /lib/firmware/nouveau -- to something else and restarted X, totem would launch fine. – Steve Jul 9 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.