My wired ubuntu18.04 box pulls a dhcp address Ok, but cannot ping any machine on subnet. It can ping localhost||its own (dhcp) ip.

# ping
From icmp_seq=1 Destination Host Unreachable

# ping # same result for 'localhost' etc
64 bytes form icmp_seq=1 ttl=64 time=0.062 ms

My router/gw is and the dhcp server is on I am typing this from a separate PC wired to the same subnet (dhcp'd to I can't ping to or from this machine from any of those.

# ip addr show enp2s0
link/ether <mac> brd <fff...>
inet brd scope global dynamic enp2s0

I'm no route expert, but these look fine (?); Note after not finding any solution, i ip route del'd ALL routes and re-ran netplan try; so these are auto-generated, and the whole table:

# ip route
default via dev enp2s0 proto dhcp src metric 100 dev enp2s0 proto kernel scope link src dev enp2s0 proto dhcp scope link src metric 

I've tried to simplify the setup of the system (all after observing the problem; AFAIK (can remember) nothing funny was done to networking config previously.

# ufw status
Status: inactive

# cat /etc/netplan/*
  version: 2
  renderer: networkd
      dhcp4: true
      dhcp6: false

# systemctl status network-manager.service
... loaded ... disabled ... inactive (dead)

Some other info in case it's helpful:

# ip link show
lo:  ... state UNKONWN
enp2s0: ... UP
enp0s31f6: ... DOWN
docker0: ... DOWN

I don't see any errors obvious in syslog or dmesg either

  • What kind of switch are you plugged into? Is it possible that the traffic is being filtered by the switch? (mac address filtering etc) – slangasek Jul 9 '19 at 4:31
  • My network is ubiquity unify (eg, managed), so thats a great question; however: the specific topology here is: dev box + laptop plugged into the same dumb switch, which is then itself plugged into the ubiquity layer2 switch. So, at least as i understand it, and should be able to talk directly through the unmanaged switch, AND anything that is configured on the unifi side (vlans, firewall, etc) would have blocked the initial DHCP if they were in play. – mike Jul 10 '19 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.