0

My wired ubuntu18.04 box pulls a dhcp address Ok, but cannot ping any machine on subnet. It can ping localhost|127.0.0.1|its own (dhcp) ip.

# ping 10.0.0.1
From 10.0.0.195 icmp_seq=1 Destination Host Unreachable

# ping 10.0.0.195 # same result for 'localhost' etc
64 bytes form 10.0.0.195: icmp_seq=1 ttl=64 time=0.062 ms

My router/gw is 10.0.0.1 and the dhcp server is on 10.0.0.2. I am typing this from a separate PC wired to the same subnet (dhcp'd to 10.0.0.217). I can't ping to or from this machine from any of those.

# ip addr show enp2s0
link/ether <mac> brd <fff...>
inet 10.0.0.195/24 brd 10.0.0.255 scope global dynamic enp2s0

I'm no route expert, but these look fine (?); Note after not finding any solution, i ip route del'd ALL routes and re-ran netplan try; so these are auto-generated, and the whole table:

# ip route
default via 10.0.0.1 dev enp2s0 proto dhcp src 10.0.0.195 metric 100
10.0.0.0/24 dev enp2s0 proto kernel scope link src 10.0.0.195
10.0.0.1 dev enp2s0 proto dhcp scope link src 10.0.0.195 metric 

I've tried to simplify the setup of the system (all after observing the problem; AFAIK (can remember) nothing funny was done to networking config previously.

# ufw status
Status: inactive

# cat /etc/netplan/*
network:
  version: 2
  renderer: networkd
  ethernets:
    enp2s0:
      dhcp4: true
      dhcp6: false

# systemctl status network-manager.service
... loaded ... disabled ... inactive (dead)

Some other info in case it's helpful:

# ip link show
lo:  ... state UNKONWN
enp2s0: ... UP
enp0s31f6: ... DOWN
docker0: ... DOWN

I don't see any errors obvious in syslog or dmesg either

  • What kind of switch are you plugged into? Is it possible that the traffic is being filtered by the switch? (mac address filtering etc) – slangasek Jul 9 at 4:31
  • My network is ubiquity unify (eg, managed), so thats a great question; however: the specific topology here is: dev box + laptop plugged into the same dumb switch, which is then itself plugged into the ubiquity layer2 switch. So, at least as i understand it, 10.0.0.195 and 10.0.0.217 should be able to talk directly through the unmanaged switch, AND anything that is configured on the unifi side (vlans, firewall, etc) would have blocked the initial DHCP if they were in play. – mike Jul 10 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.