0

In Virtual Box 6.0.8 (on Ubuntu 18.04 host), I'm running an Ubuntu 18.04 live CD image as guest (so, not installed).

So, I tried to run gnome-control-center, because I want to try to disable mouse integration (as per this SuperUser answer; Guest Additions have been installed); but if I run:

ubuntu@ubuntu:~$ gnome-control-center 
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.

#9889 (OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.) – Oracle VM VirtualBox:

User that issues startx, should be part of group: vboxguest

OK:

ubuntu@ubuntu:~$ sudo usermod -a -G vboxguest ubuntu
usermod: group 'vboxguest' does not exist

ubuntu@ubuntu:~$ sudo groupadd vboxguest 
ubuntu@ubuntu:~$ sudo usermod -a -G vboxguest ubuntu
ubuntu@ubuntu:~$ gnome-control-center 

(gnome-control-center:10127): dbind-WARNING **: 20:37:38.574: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.

Right, but if I run as sudo, this warning appears:

ubuntu@ubuntu:~$ sudo gnome-control-center 
OpenGL Warning: crPixelCopy3D:  simply crMemcpy'ing from srcPtr to dstPtr

... and a window gets raised, however it's empty:

vbox-gnomecc

Any ideas how I could properly start gnome-control-center in this case (liveCD image as VirtualBox guest)?

0

From what I found in: #18239 (No Mouse visibility on VM -> fixed in releases after 6.0.4) – Oracle VM VirtualBox:

In "VirtualBox > Settings > Display" for the guest, I changed the "Graphics Controller" to "VBoxSVGA" [...]

VBoxSVGA is the wrong option, as it's used for Win guests. Are you sure you didn't change it to VMSVGA, which is the proper one for Linux guests?

I shut down the guest VM, changed the display to VMSVGA, booted guest again, and now gnome-control-center starts in full.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.