0

I’m running Lubuntu on a MacBook Pro 2011 with a burnt graphics card. I managed 2 years ago to switch it completely to Lubuntu Xenial and it all worked fine until I upgraded to Bionic Beaver last year. All still works fine except for the software updates which haven’t updated even once since the upgrade from 16.04 to 18.04.

In the Terminal I do a sudo apt-get update (runs fine) followed by an apt-get upgrade. I get the following:

$ sudo apt-get update
Hit:1 http://mirrors.neterra.net/ubuntu bionic InRelease
Hit:2 http://mirrors.neterra.net/ubuntu bionic-updates InRelease
Hit:3 http://mirrors.neterra.net/ubuntu bionic-backports InRelease
Hit:4 http://mirrors.neterra.net/ubuntu bionic-security InRelease
Reading package lists... Done
$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Graphic interface works similarly. In Software Updater I get a "The software of this computer is up-to-date" message, which it definitely cannot be.

I suppose there's a broken repository link but I can't figure this out by myself. How do I solve this issue?

My configuration is:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu Bionic Beaver (development branch)
Release:    18.04
Codename:   bionic

Computer:
Processor : Intel(R) Core(TM) i7-2635QM CPU @ 2.00GHz
Memory : 3949MB (2219MB used)
Machine Type : Notebook
Operating System : Ubuntu Bionic Beaver (development branch)
User Name : bo (bo)
Date/Time : Sun 07 Jul 2019 15:20:41 EEST

Display:
Resolution : 1440x900 pixels
OpenGL Renderer : (Unknown)
X11 Vendor : The X.Org Foundation

Audio Devices:
Audio Adapter : HDA-Intel - HDA Intel PCH

Operating System:
Kernel : Linux 4.15.0-13-generic (x86_64)
Version : #14-Ubuntu SMP Sat Mar 17 13:44:27 UTC 2018
C Library : GNU C Library / (Ubuntu GLIBC 2.27-0ubuntu3) 2.27
Distribution : Ubuntu Bionic Beaver (development branch)

Added apt history log:

~$ less /var/log/apt/history.log.1.gz

Start-Date: 2019-07-07 16:51:35

Commandline: apt full-upgrade

Requested-By: bo (1000)

Install: linux-modules-extra-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic), libwayland-egl1:amd64 (1.16.0-1ubuntu1.1~18.04.1, automatic), intel-microcode:amd64 (3.20190618.0ubuntu0.18.04.1, automatic), networkd-dispatcher:amd64 (1.7-0ubuntu3.3, automatic), python3-dateutil:amd64 (2.6.1-1, automatic), libllvm8:amd64 (1:8-3~ubuntu18.04.1, automatic), linux-modules-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic), libbrotli1:amd64 (1.0.3-1ubuntu1.2, automatic), linux-headers-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic), iucode-tool:amd64 (2.3.1-1, automatic), libwoff1:amd64 (1.0.2-1build0.1, automatic), ...

...

...shim:amd64 (13-0ubuntu2, 15+1533136590.3beb971-0ubuntu1)

End-Date: 2019-07-08 00:10:23

~$ less /var/log/apt/history.log.2.gz

Start-Date: 2019-06-16 17:26:50

Commandline: /usr/sbin/synaptic

Requested-By: bo (1000)

Install: libopencore-amrnb0:amd64 (0.1.3-2.1,automatic), libopencore-amrwb0:amd64 (0.1.3-2.1, automatic), gstreamer1.0-libav:amd64 (1.14.0-1, automatic), libsidplay1v5:amd64(1.36.59-11, automatic), soundconverter:amd64 (3.0.0-2), gstreamer1.0-plugins-ugly:amd64 (1.14.0-1, automatic)

End-Date: 2019-06-16 17:31:06

~$ less /var/log/apt/history.log.3.gz

Start-Date: 2019-04-08 22:45:52

Commandline: apt install debian-keyring

Requested-By: bo (1000)

Install: debian-keyring:amd64 (2018.03.24)

End-Date: 2019-04-08 22:46:41

  • Have you tried sudo apt update and followed that up with sudo apt full-upgrade? Also try changing your server to the main server rather than what you have (mirrors.neterra.net). – DK Bose Jul 7 at 13:05
  • Please edit your question to show us the complete output of this command: tail -n20 /var/log/apt/history.log. It simply displays the last 20 lines of that particular logfile. – user535733 Jul 7 at 14:03
  • 1
    Thanks @DK Bose, sudo apt update followed by apt full-upgrade did not make any change. Changing the server and then running the update/full-upgrade got the system to upgrade 794 packages. It’s still underway. I think this should do the job. – Bo Baka Jul 7 at 14:06
  • @user535733, I ran the command but it listed an unreasonably large number of lines to add them to my question (I'm only afraid this may look like spamming the topic but I can't really judge). If you think this would add to the value of this please let me know and I'll add it. Before the big chunk starts I get the following output: >~$ tail -n20 /var/log/apt/history.log Start-Date: 2019-07-07 16:51:35 Commandline: apt full-upgrade Requested-By: bo (1000) – Bo Baka Jul 7 at 21:29
  • You are correct - you are offering to post history of what happened earlier today. We don't want that. Use the less command to browse through your history.log.1.gz file (less /var/log/apt/history.log.1.gz) for events and upgrades from last month. Tell us if the file is empty, or if it has lots of entries. If it has lots of entries, tell us a couple dates with lots of actiity. – user535733 Jul 7 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.