1

This question already has an answer here:

As can be seen on the title, I got the "Failed to fetch... Hash Sum mismatch" Error. I have tried this method:

  1. Deleting /var/lib/apt/lists/* does not work...
  2. Thinking, if I'm behind a proxy, I tried fixing "Hash Sum Mismatch" like this:

    By Creating a file /etc/apt/apt.conf.d/99fixbadproxy with this content

    Acquire::http::Pipeline-Depth 0;

    Acquire::http::No-Cache true;

    Acquire::BrokenProxy true;

  3. I tried several other solutions provided on askubuntu however, it doesn't work.

Have a look at my error on the terminal.

Screenshot of the Error obtained in the Terminal

marked as duplicate by karel, Kulfy, Fabby, Volker Siegel, Thomas Jul 14 at 11:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Well, this might be the issue of caches within your ISP. These packages are distributed across multiple locations for making available globally, due to such this packages sometimes not get the updates at a given time in some location so thus you faced this hash sum error.

I would recommend you to perform this action via changing proxy address/ VPN which will change the IP.

0

This solution finally worked out for me:

  1. sudo rm -rf /var/lib/apt/lists/*
  2. sudo apt-get update -o Acquire::CompressionTypes::Order::=gz
  3. sudo apt-get update && sudo apt-get upgrade

Source: https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1785778

Not the answer you're looking for? Browse other questions tagged or ask your own question.