0

This question already has an answer here:

When I run sudo apt update, I get a 404 Not Found error:

me@K2SO:~$ sudo apt update
Ign:1 http://developer.download.nvidia.com/compute/machine-learning/repos/ubuntu1604/x86_64  InRelease
Hit:2 http://developer.download.nvidia.com/compute/machine-learning/repos/ubuntu1604/x86_64  Release                                                                                    
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                            
Hit:4 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                                                       
Hit:5 http://security.ubuntu.com/ubuntu disco-security InRelease                                                                                                                        
Hit:6 http://us.archive.ubuntu.com/ubuntu disco InRelease                                                                                                                      
Hit:7 https://updates.signal.org/desktop/apt xenial InRelease                                                                                   
Hit:8 http://dl.google.com/linux/chrome/deb stable Release          
Hit:9 http://us.archive.ubuntu.com/ubuntu disco-updates InRelease   
Hit:11 http://ppa.launchpad.net/samoilov-lex/sway/ubuntu disco InRelease
Hit:12 http://us.archive.ubuntu.com/ubuntu disco-backports InRelease
Ign:13 http://ppa.launchpad.net/simonschneegans/testing/ubuntu disco InRelease
Hit:15 http://ppa.launchpad.net/snwh/ppa/ubuntu disco InRelease
Err:16 http://ppa.launchpad.net/simonschneegans/testing/ubuntu disco Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/simonschneegans/testing/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

It's my understanding that 19.04 is still currently supported, and there's nothing else to upgrade to. I tried using the solution outlined here, but that's way back from 2014, and it didn't work.

How do I fix this error?

marked as duplicate by Kulfy, karel, mikewhatever, Zanna, Fabby Jul 13 at 20:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    19.04 does not appear to be currently supported by the simonschneegans/testing PPA – steeldriver Jul 6 at 19:13
  • 1
    PPA's are 3rd party software sources; you must check they support your release, are well maintained. etc - that PPA appears to have last been supported in late 2018. – guiverc Jul 6 at 19:31
2

The PPA at http://ppa.launchpad.net/simonschneegans/testing/ubuntu doesn't support disco yet, but they do support cosmic.

Let's fix this...

Search for the appropriate .list file to edit, with grep -i simonschneegans /etc/apt/sources.list.d/*.list, and then edit your {found_file_name} with sudo -H gedit /etc/apt/sources.list.d/found_file_name.list and change disco to cosmic.

Not the answer you're looking for? Browse other questions tagged or ask your own question.