1

I have the issue where every time I boot up my laptop it shows the boot menu and I have to choose that I want to use Ubuntu. I have searched the web and found that others have the same issue, however the solutions that has worked for them where they set the timer to 0 do not work for me.

What I have tried:

sudo nano /etc/default/grub
GRUB_TIMEOUT=0

Then i ran sudo update-grub.

I still have the issue. I run a fresh installation of Ubuntu 18.04.2.

This file looks like the following:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT=0.1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
  • is it dual boot or single? – Mogli Jul 6 at 11:29
  • It is singel boot – Jesper.Lindberg Jul 6 at 12:54
1

What you tried:

sudo nano /etc/default/grub
GRUB_TIMEOUT=0

Then run sudo update-grub

Does not work because grub automatically changes a time out of zero to 10. What you need to do is this:

sudo nano /etc/default/grub
GRUB_RECORDFAIL_TIMEOUT=0.1
GRUB_TIMEOUT=0.1

Then run sudo update-grub

  • This did not help, tried 1 as well. – Jesper.Lindberg Jul 6 at 21:07
  • @Jesper.Lindberg I added an additional option. If it still doesn't work please update your question with the entire contents of your /etc/default/grub file. – WinEunuuchs2Unix Jul 6 at 21:37
  • Did not help, I have updated my first post with the content of the file. – Jesper.Lindberg Jul 6 at 22:03
  • @Jesper.Lindberg I've added another option. – WinEunuuchs2Unix Jul 6 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.