I'm trying to install the poweriso sh file (along with other sh files) onto my system, but it doesn't seem to work ( the outcome is the same on all sh files). I did some research on how to install sh files, various forums and youtube videos seem to conclude that I am in fact doing it right. but why isn't it installing? when I run

sudo chmod +x poweriso.sh 


sudo chmod +x ./poweriso.sh 

they gave me the same output, which is nothing, literally nothing, like I didn't even type anything. no error, nothing. what am I doing wrong?

  • The command chmod does not run a script, only changes if it's executable or not. After marking it as executable, you have to execute it: ./poweriso.sh – guillermo chamorro Jul 5 at 19:29
  • Hi, I just typed sudo chmod +x poweriso.sh then sudo poweriso.sh but it returned with bash: poweriso.sh: command not found Am I missing something? :( – Luke Watson Jul 5 at 19:34
  • same outcome sudo: ./poweriso.sh: command not found – Luke Watson Jul 5 at 19:39
  • @LukeWatson in that case, a file of the name poweriso.sh does not exist in the current directory – steeldriver Jul 5 at 21:17

The command chmod does not run a script. It only marks it as executable or not.

You can verify if a file is executable running the command ls -l your_file, which will output something like this:

-rw-r--r--  1 user  user          0 jul  5 16:34 your_file

As you see there is no x in the first column, meaning that the file is not executable.

Let's the mark it as executable:

$ chmod +x your_file

Check again with ls -l your_file:

-rwxr-xr-x  1 user  user          0 jul  5 16:34 your_file

Now the x means that it is executable and you can run it typing

$ ./your_file

Note: There's of course the matter of permissions, users and groups, but that's another monster that may make the answer much more complicated than needed.

  • Hi, I tried running chmod +x poweriso then ls -l poweriso but instead of giving me x, it gives me -rw-r--r-- 1 luke luke 1929800 Mar 19 04:55 poweriso attempting to run it results in bash: ./poweriso: Permission denied – Luke Watson Jul 5 at 21:07
  • 1
    @LukeWatson please edit your question to include the output of findmnt -T ./ – steeldriver Jul 5 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.