0

I recently made the switch to ubuntu and have been working around adding packages and all. Now, during startup I encounter the following error always.

Error found when loading /home/usr/.profile:
/home/usr/.profile:line 29: E:: command not found
/home/usr/.profile:line 30: Try: command not found
As a result the session will not be configured correctly.
You should fix the problem as soon as feasible.

Any possible solution to this. Thanks in advance.

my .profile file looks like this ,

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/.local/bin" ] ; then
    PATH="$HOME/.local/bin:$PATH"
fi
eval $(E: Linuxbrew directory detected, but it seems broken.
   Try to remove '/home/linuxbrew/.linuxbrew' and install again./bin/brew shellenv)

  • 3
    Yes, fix the errors in line 29 and 30 in .profile. Or at least, update the question with the content of .profile so some one here can have a look at it. – Soren A Jul 5 '19 at 12:35
  • 2
    I gather you've changed your $USER (username) to be 'usr' (/usr/ is a special directory in unix) - but look at your .profile file & correct errors on lines 29 and 30. We can't see those lines, so can't see what you've done to them (but I'd hope it would be obvious; turning the lines into comments ("# " at start of those lines) would be easiest fix. – guiverc Jul 5 '19 at 12:37
0

In terminal...

gedit /home/usr/.profile

Open gedit preferences, and enable line numbering...

enter image description here

Locate lines 29-30.

Copy lines 25-35 to the clipboard.

Edit your question here, paste in the clipboard, select the pasted text, hit the {} icon to make the text human readable.

I'll look at it and suggest a fix.

Update #1:

Remove the two lines at the end of .profile...

eval $(E: Linuxbrew directory detected, but it seems broken.
   Try to remove '/home/linuxbrew/.linuxbrew' and install again./bin/brew shellenv)
  • Did it sir. Kindly look into it. – Duke Nukem Jul 5 '19 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.