My wifi card is an Intel® Wireless-AX200 (802.11/a/b/g/n/ac/ax), Bluetooth® 5, and bluetooth is working. I've tried following various guides, however these drivers are apparently yet to make it into the kernel.

Their product brief states linux is supported:


And yet their driver page has no listing for them:


sudo lshw -c network
mark@m-blade-2019:~$ sudo lshw -c network
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:cf300000-cf303fff
       description: Ethernet interface
       physical id: 2
       logical name: enx0050b6b47e72
       serial: 00:50:b6:b4:7e:72
       capabilities: ethernet physical
       configuration: broadcast=yes driver=cdc_ncm driverversion=22-Aug-2005 firmware=CDC NCM ip= link=yes multicast=yes

I'm running kernel version Linux 5.0.0-13-generic, any help is greatly appreciated.

EDIT: results of lspci -nnk | grep 00280 -A3:

mark@m-blade-2019:~$ lspci -nnk | grep 0280 -A3
02:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a)
    Subsystem: Intel Corporation Device [8086:0084]
    Kernel modules: wl, iwlwifi
03:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981 [144d:a808]

  • 1
    Please edit your question to show the result of the terminal command: lspci -nnk | grep 0280 -A3 Thanks.
    – chili555
    Jul 5, 2019 at 14:27

6 Answers 6


A newer version of iwlwifi can be installed that includes your device and, crucially, the exact subsystem. With a working internet connection by ethernet, tethering or whatever means possible, open a terminal and do:

sudo apt update
sudo apt install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi/
make defconfig-iwlwifi-public
make -j4
sudo make install
sudo modprobe iwlwifi

I am not certain that the firmware is included in the latest version of linux-firmware. If your device doesn't start working immediately, check the log for messages and we'll then address the firmware if it's missing.

dmesg | grep iwl
  • If it does not work immediately, usually it is due to Secure Boot. Then the user has to choose between signing the installed firmware or turning off Secure Boot
    – prusswan
    Jul 11, 2019 at 17:17
  • Worked like a charm on my new Dell Precision 5540 with the Intel AX200 wireless component. If I could reach through the Internet, I'd buy you all a well deserved beer. Thanks!
    – trinkner
    Aug 7, 2019 at 0:45
  • 1
    Worked for me on my thinkpad x1 extreme gen2, on pop!_os lts version. Thanks Oct 18, 2019 at 8:31
  • 1
    Didn't work in my case. I got SSL error:02001002:system library:fopen:No such file or directory: bss_file.c:175 error message during sudo make install. (Ubuntu 16.04.6 LTS, kernel 4.5.0-88-generic.) @chili555, Do you happen to know what might be the possible reason for this error?
    – IgNite
    Mar 17, 2020 at 4:54
  • 1
    @chili555, Well, actually, after doing the above steps, the Wifi gets detected. But when I try connecting to the secured Wifi, my Ubuntu 16.04.6 completely freezes.
    – IgNite
    Mar 17, 2020 at 5:02

According to these articles, support for this card is in kernel 5.1.*.


"The product page does list Linux support that comes as little surprise these days. In fact, back in January we wrote about Linux support for these new Intel adapters within the "IWLWIFI" driver and that enablement is now present in the Linux 5.1 kernel."


"The Intel WiFi Linux driver "IWLWIFI" will see support for various new WiFi adapters with the upcoming Linux 5.1 kernel cycle."

These kernels can be downloaded from https://kernel.ubuntu.com/~kernel-ppa/mainline/, or by using ukuu $12, from https://teejeetech.in/ukuu/

  • 1
    Forcing an upgrade to 5.1.0 (the only one not to crash on boot for me out of 4 or 5), wifi and bluetooth both work out the box. Thanks!
    – Mark
    Jul 5, 2019 at 19:58

stolen from here : https://unix.stackexchange.com/a/518577/228658 since can't mark as duplicate of a unix stack exchange page :

According to the product page it's a pre-certified solution and the driver has not been published yet.

Even Linus's Development branch doesn't reveal anything so I'm assuming that at the time of this writing, it's not Linux compatible yet and the article you're referring to uses marketing speak for: We'll be adding that soon...

  • Linus's dev branch now shows two entries for AX200 in what appears to be v 5.4.
    – EdwinW
    Jun 17, 2020 at 4:00

For those who run into this and find that upgrading the kernel alone does not fix it. I had to also install the latest firmware as listed here: https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html. The one corresponding to Intel® Wi-Fi 6 AX200 160MHz.

  • That was it! Thank you. Without this suggestion, I was getting nowhere. :) Sep 30, 2021 at 4:02

If you are willing to switch your kernel from the generic one to the OEM kernel, you can try the linux-oem-osp1 package. This kernel is for certified OEM machines and is based on 19.04's 5.0 kernel, AX200 support has been backported to it.

Apart from kernel driver update, you also need to update the linux-firmware package to the latest version, so you should run:

$ sudo apt install linux-oem-osp1 linux-firmware
  • Upgrading to Ubuntu 20.04 also worked for me. Reading about the OEM kernel that you linked to I saw that "the delta in OEM kernel should all be merged to the generic kernel in the next Ubuntu release". (Might have added as separate answer if I had enough reputation.)
    – ArneHugo
    May 8, 2020 at 22:09
  • 1
    @ArneHugo you're right, now it's time to try 20.04 as it has already been released. When I gave my answer 20.04 didn't exist. May 26, 2020 at 2:01

Here's the solution that worked for me after the above solutions failed on a new Dell 9th gen XPS. This does involve a little custom patch so please review the code to feel comfortable with it. On a fresh install you also need git.

sudo apt install build-essential dkms git
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
wget https://raw.githubusercontent.com/sibblegp/AX200-Patch/master/dkms.patch
patch -p1 < dkms.patch
rm dkms.patch
cd ..
sudo mv backport-iwlwifi /usr/src
sudo su
cd /usr/src
mv backport-iwlwifi/ backport-iwlwifi-git
dkms add backport-iwlwifi/git
dkms build backport-iwlwifi/git
dkms install backport-iwlwifi/git
modprobe iwlwifi

And it should be up and running! I ran this on bare Ubuntu 18.04.3 LTS.

  • Just a note @george-sibble, the patch is failing on module.h on the latest 5.0 kernel. Looks like the cold attribute was added to both functions. It works if you just plop those attributes into the patch so the hunks succeed.
    – stuckj
    Jan 2, 2020 at 20:22
  • @stuckj Could you share what steps we have to follow for adding the attributes into the patch? Jan 29, 2020 at 18:10
  • 2
    @Nivii1406, you follow his instructions above except that after the wget call, edit the downloaded dkms.patch file. There are 4 lines you need to modify (line numbers 43-44 and 52-53). Those lines have the removal of a function definition and an add of a modified version of that function definition. You'll find text that looks like alias(.... Put this text in front of each of the alias(... parts: cold,. That's cold followed by a comma. I'm not sure if you're a developer so I tried to make the instructions very clear above. :)
    – stuckj
    Jan 29, 2020 at 18:22
  • 2
    Here's a link to the file with my modifications. raw.githubusercontent.com/stuckj/AX200-Patch/master/dkms.patch. I made a PR to @George-Sibble's repo as well.
    – stuckj
    Jan 29, 2020 at 18:31
  • Thanks a bunch! I was not sure about what I was doing, so this definitely helps! :) Jan 29, 2020 at 22:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .