5

My wifi card is an Intel® Wireless-AX200 (802.11/a/b/g/n/ac/ax), Bluetooth® 5, and bluetooth is working. I've tried following various guides, however these drivers are apparently yet to make it into the kernel.

Their product brief states linux is supported:

https://www.intel.com/content/www/us/en/products/docs/wireless/wi-fi-6-ax200-module-brief.html

And yet their driver page has no listing for them:

https://downloadcenter.intel.com/product/189347

sudo lshw -c network
=>
mark@m-blade-2019:~$ sudo lshw -c network
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:cf300000-cf303fff
  *-network
       description: Ethernet interface
       physical id: 2
       logical name: enx0050b6b47e72
       serial: 00:50:b6:b4:7e:72
       capabilities: ethernet physical
       configuration: broadcast=yes driver=cdc_ncm driverversion=22-Aug-2005 firmware=CDC NCM ip=192.168.1.17 link=yes multicast=yes

I'm running kernel version Linux 5.0.0-13-generic, any help is greatly appreciated.

EDIT: results of lspci -nnk | grep 00280 -A3:

mark@m-blade-2019:~$ lspci -nnk | grep 0280 -A3
02:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a)
    Subsystem: Intel Corporation Device [8086:0084]
    Kernel modules: wl, iwlwifi
03:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981 [144d:a808]
mark@m-blade-2019:~$ 

  • 1
    Please edit your question to show the result of the terminal command: lspci -nnk | grep 0280 -A3 Thanks. – chili555 Jul 5 at 14:27
  • 1
    Updated and thanks – Mark Jul 5 at 17:22
7

According to these articles, support for this card is in kernel 5.1.*.

https://www.phoronix.com/scan.php?page=news_item&px=Intel-WiFi-6-AX200-Cyclone-Peak

"The product page does list Linux support that comes as little surprise these days. In fact, back in January we wrote about Linux support for these new Intel adapters within the "IWLWIFI" driver and that enablement is now present in the Linux 5.1 kernel."

https://www.phoronix.com/scan.php?page=news_item&px=Intel-IWLWIFI-22260-WiFI-Linux

"The Intel WiFi Linux driver "IWLWIFI" will see support for various new WiFi adapters with the upcoming Linux 5.1 kernel cycle."

These kernels can be downloaded from https://kernel.ubuntu.com/~kernel-ppa/mainline/, or by using ukuu $12, from https://teejeetech.in/ukuu/

  • 1
    Forcing an upgrade to 5.1.0 (the only one not to crash on boot for me out of 4 or 5), wifi and bluetooth both work out the box. Thanks! – Mark Jul 5 at 19:58
9

A newer version of iwlwifi can be installed that includes your device and, crucially, the exact subsystem. With a working internet connection by ethernet, tethering or whatever means possible, open a terminal and do:

sudo apt update
sudo apt install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi/
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
sudo modprobe iwlwifi

I am not certain that the firmware is included in the latest version of linux-firmware. If your device doesn't start working immediately, check the log for messages and we'll then address the firmware if it's missing.

dmesg | grep iwl
  • If it does not work immediately, usually it is due to Secure Boot. Then the user has to choose between signing the installed firmware or turning off Secure Boot – prusswan Jul 11 at 17:17
  • Worked like a charm on my new Dell Precision 5540 with the Intel AX200 wireless component. If I could reach through the Internet, I'd buy you all a well deserved beer. Thanks! – trinkner Aug 7 at 0:45
  • Worked for me as well on Mint 19.2 Tina with kernel 5.0.0.25-generic. Thanks! – Alf 2 days ago
1

stolen from here : https://unix.stackexchange.com/a/518577/228658 since can't mark as duplicate of a unix stack exchange page :

According to the product page it's a pre-certified solution and the driver has not been published yet.

Even Linus's Development branch doesn't reveal anything so I'm assuming that at the time of this writing, it's not Linux compatible yet and the article you're referring to uses marketing speak for: We'll be adding that soon...

1

For those who run into this and find that upgrading the kernel alone does not fix it. I had to also install the latest firmware as listed here: https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html. The one corresponding to Intel® Wi-Fi 6 AX200 160MHz.

0

If you are willing to switch your kernel from the generic one to the OEM kernel, you can try the linux-oem-osp1 package. This kernel is for certified OEM machines and is based on 19.04's 5.0 kernel, AX200 support has been backported to it.

Apart from kernel driver update, you also need to update the linux-firmware package to the latest version, so you should run:

$ sudo apt install linux-oem-osp1 linux-firmware
0

Here's the solution that worked for me after the above solutions failed on a new Dell 9th gen XPS. This does involve a little custom patch so please review the code to feel comfortable with it.

sudo apt install build-essential dkms
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
wget https://raw.githubusercontent.com/sibblegp/AX200-Patch/master/dkms.patch
patch -p1 < dkms.patch
rm dkms.patch
cd ..
sudo mv backport-iwlwifi /usr/src
sudo su
cd /usr/src
mv backport-iwlwifi/ backport iwlwifi-git
dkms add backport-iwlwifi/git
dkms build backport-iwlwifi/git
dkms install backport-iwlwifi/git
modprobe iwlwifi
exit

And it should be up and running! I ran this on bare Ubuntu 18.04.3 LTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.