2

I am currently trying out KDevelop 5.2.1 for a C++ project on Ubuntu 18 and so far, everything is working as expected, except syntax coloring. I have not been able to personalize it the way I want. What I am doing is the following:

  1. Settings -> Configure KDevelop... -> Editor -> Fonts & Colors
  2. New Schema
  3. There I change the colors, default text styles and Highlight text style (for C++)

When I change colors there, some have the wanted effect (ex.: backgroung) but others seem to have no effect (ex.: macros). For example, for a custom macro function, I have not been able so far to change from the blue/greeninsh default coloring. Same for custom types or variables (which seem to be randomly colored).

In Highlighting Text Style, I have tried setting everything to white and to my surprise, most of the code is still colored (I was looking at a .cpp file).

Is there something I am doing wrong? How can I change these colors?

2

The editor settings are inherited from KTextEditor, and apply when KDevelop's semantic highlighting doesn't override them, e.g. for files not in a supported language.

The hues used for semantic highlighting aren't configurable currently.

They're blended with the underlying editor colour; the intensity is configurable under "Configure KDevelop -> Language Support", including disabling it by setting this to zero.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.