1

In Ubuntu 18.04, if I click Super+Space, (where Super can be a key marked with Windows logo), I can change keyboard layouts, which is followed with a window overlay or notification (or whatever you wanna call it), which looks like this:

kbd

As leftover from my Windows days, I also mapped Left Alt+Shift to change keyboard layout - which it does, however without raising the above window/notification.

Is there a way to set up Gnome3, so that this keyboard layout window/notification is also raised when I hit Left Alt+Shift?

2

Those are two ways to do it. You should probably first disable the Left Alt+Shift shortcut the way you activated it (assuming you used Tweaks).

Next go to Settings -> Devices -> Keyboard -> Typing. From there you can change the shortcuts for the built-in way to do it - with the overlay - rather than adding a new shortcut.

2
  • Many thanks, @GunnarHjalmarsson - indeed, it seems I had used Gnome Tweaks to set the shortcut ("Additional layout options"). Instead of "Typing", I see Settings -> Devices -> Keyboard -> Keyboard Shortcuts, and then have to scroll down to see Typing category. I was about to ask - can I keep both Alt+Shift and Super+Space shortcuts, but there are two there: previous and next layout, so for next I can use alt+shift, for previous I can keep Super+Space. Except, I get a "Set Shortcut" window asking me to press key combo, and it doesn't detect alt+shift - any workarounds?
    – sdaau
    Jul 5 '19 at 2:34
  • @sdaau: Hmm.. You are right - it doesn't accept only <Alt>+<Shift>. Then my answer is not very good. And no, I don't know how you would work around that limitation. Only thing I can say, then, is that you can have both - just as you have already - but without the overlay for <Alt>+<Shift>. If the overlay is important (why is that, btw?), then try to get used to <Super>+<Space> or some other combination which it does accept. Jul 6 '19 at 3:37
0
  • Easy but bit laggy:
    Use gnome-tweaks (install), under Keyboard and Mouse, Click Additional Layout Options, and you can enable Alt_shift.
    However using this made alt key "too sticky" for me, and on fast alt+shift click it would popup a menu as if you clicked only alt. [and since i'd be typing, it would also result in some unwanted action]

Works better, breaks backwards switch, which is irrelevant for only 2 input sources:

  1. Use gsettings to set the switch-keyboard-source shortcut in settings to alt+shift.
    You have to choose a side for alt or shift for this to work. Fine with me as a I almost only use left shift for this.
    Examples; Choose one that suit you:
gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Alt>Shift_R']"
gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Alt>Shift_L']"
gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Shift>Alt_R']"
gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Shift>Alt_L']"
  1. Use gsettings / settings gui to set switch-keyboard-input-backward to Super+Space
gsettings set org.gnome.desktop.wm.keybindings switch-input-source-backwards "['<Super>Space']"

Works great for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.