I'm trying to install this according to this guide, but when I go to install libqt5gamepad5-dev, I get "Package not found". I've sudo apt update'd multiple times to no avail. How do I fix this problem?

  • The package package is only available for cosmic up (18.10-), packages.ubuntu.com/… and looking at some of its requirements they require more modern packages than bionic provides (libqt5core5a: packages.ubuntu.com/cosmic/libqt5gamepad5 packages.ubuntu.com/bionic/libqt5core5a) so it could risk pulling your 18.04 away from LTS security (ie. causing parts of your system to go EOL next month with 18.10). Jumping to a later release is an option. – guiverc Jul 4 '19 at 1:41
  • Excuse my ignorance, but how do I jump to a later release? – anonaii Jul 4 '19 at 1:44
  • Ubuntu 18.04 LTS offers two upgrade paths, (1) to Ubuntu 18.10 available now, see wiki.ubuntu.com/CosmicCuttlefish/ReleaseNotes in the Upgrading from Ubuntu 18.04 section., or (2) upgrading to Ubuntu 20.04.1 LTS (which won't be out till mid-2020; note it's the first .1 release so not in April). 18.10 reaches EOL next month, so you'll need to jump again to 19.04 very soon as standard releases come out every 6 months and are supported for 9 months giving you 3 months to release-upgrade. – guiverc Jul 4 '19 at 1:48
  • Thank you! I think I'll upgrade to 18.10 for the time being, then jump to 19.04 – anonaii Jul 4 '19 at 1:50
  • ps: just because that's the best I can provide doesn't mean someone else won't have other ideas. You may get a gamer who's came across this issue and thus has the drive & spent the time to come up with a solution, so you may find alternatives if you're patient. – guiverc Jul 4 '19 at 1:51

That's right, the package libsq5gamepad5 and it's associated -dev are not in the 18.04 repositories. They were added to Ubuntu during the later 18.10 cycle, and are in releases of Ubuntu 18.10 and newer.

Deb packages in the repositories are re-built for each new release of Ubuntu. The easiest way to use the package is to migrate to a newer release of Ubuntu that has the package.

We generally recommend against trying to use a wrong-release package on your Ubuntu system. While an expert may (or may not) be able to make it work using a bit of dpkg magic, a new user is much more likely to merely break their system.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.