0
  1. I have Apache 2.4(installed using apt get) and 2.2(manually installed) in my machine.
  2. I have PHP versions 7.3.6 and 5.6 installed.
  3. Apache 2.4 with PHP version 7.3.6 configuration is successfully done in port 80.

Now I try to configure PHP 5.6 version to Apache 2.2 in port 81. I have followed the steps.

  • I have copied /usr/lib/apache2/modules/libphp5.6.so to modules/ folder
  • Made following changes to httpd.conf

    LoadModule php5_module modules/libphp5.6.so

    SetOutputFilter PHP SetInputFilter PHP LimitRequestBody 9524288

    AddType application/x-httpd-php .php AddType application/x-httpd-php-source .phps

When I try to start my Apache 2.2, system shows following error.

sudo /opt/webserver/bin/apachectl start

httpd: Syntax error on line 423 of /opt/webserver/conf/httpd.conf: Cannot load /opt/webserver/modules/libphp5.6.so into server: /opt/webserver/modules/libphp5.6.so: undefined symbol: ap_log_error_

Please let me know what I am wrong and suggest some solution. Thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.