1

After resizing the root and home partition kubuntu is not booting properly, I googled it and found out that it may be due to the change in position of my partitions but I don't know how to fix it, The boot.log is available here:https://pastebin.com/NDRpuyEH (Output Updated with better formating)

The output requested is posted below

enter image description here

ak@ak-pc:~$ lsblk -f
NAME   FSTYPE   LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0  squashfs                                                            0   100% /snap/kde-frameworks-5-core18/29
loop1  squashfs                                                            0   100% /snap/core18/1013
loop2  squashfs                                                            0   100% /snap/core18/1049
sda                                                                                 
├─sda1 ntfs     System Reserved 72861FE7861FAA9D                                    
├─sda2 ntfs                     01D51E18BABD6380                                    
├─sda3 ntfs                     AC4A56F84A56BEB0                       34.5G    91% /media/ak/AC4A56F84A56BEB0
├─sda4                                                                              
├─sda5 ext4                     0eb0c8ed-71f7-411b-9bf7-14641e0478b6   11.4M    86% /boot
├─sda6 ext4                     bdba4a49-e26f-42e5-8ee4-36ad71d2d8ef    2.1G    70% /
├─sda7 ext4                     e3267fa3-335d-473f-8e9f-d92320695b4f    6.8G    32% /home
└─sda8 swap                     dc2cd463-e46e-4cbd-b14f-ed811bf6526c                
sdb                                                                                 
└─sdb1 vfat     AK 16GB         1442-78BB                               1.9G    87% /media/ak/AK 16GB
sr0                                                                                 
ak@ak-pc:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#                
# / was on /dev/sda6 during installation
UUID=bdba4a49-e26f-42e5-8ee4-36ad71d2d8ef /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda5 during installation
UUID=0eb0c8ed-71f7-411b-9bf7-14641e0478b6 /boot           ext4    defaults        0       2
# /home was on /dev/sda8 during installation
UUID=e3267fa3-335d-473f-8e9f-d92320695b4f /home           ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=c82e3e5c-866b-4a16-9153-a73129281e82 none            swap    sw              0       0
  • 1
    Did you reformat a partition? It says this is an issue. /dev/disk/by-uuid/c82e3e5c-866b-4a16-9153-a73129281e82 Best to also post above with formatting to make it easy to read lsblk -f to see UUID and cat /etc/fstab to see what it is trying to mount at that UUID. – oldfred Jul 3 at 3:34
  • I decrease the size of /home partition and then I delete the swap partition and finally I moved the unallocated space above the home partition and increase the size of root partition and created a new linux-swap – A.K. Jul 3 at 3:48
  • 1
    Your fstab (file system table) probably still tells your system to wait for your old swap to mount (until timeout), did you change it to have it not try & load the old partition (now deleted) swap partition, and have instead use your new swap instead (if it was partition instead of swapfile in your mention of created a new linux-swap). You haven't told us your release, so swapfile may not be an option. – guiverc Jul 3 at 4:39
  • 1
    The UUID for your swap-partition is wrong in /etc/fstab, you have to change the UUID to the one you got from your lsblkoutput. – mook765 Jul 3 at 8:06
  • 1
    @A.K. That's the way to go... – mook765 Jul 3 at 11:23
2

Partitions are normally mounted by UUID as UUIDs do not change. But if you delete & recreate a partition like swap, then it gets a new UUID and you must update /etc/fstab with correct UUID. Others can have similar issues with any other partition they mount. But if / (root) system would not boot at all.

To see UUID of partitions:

sudo lsblk -f

And to see UUIDs used at boot to mount partitions.

cat /etc/fstab

If any partitions in fstab have UUIDs not shown by the lsblk -f command, you need to edit fstab. You need sudo and can use your favorite editor. Always good idea to backup old version.

sudo cp /etc/fstab /etc/fstab.backup
sudo nano /etc/fstab

UUID=c82e3e5c-866b-4a16-9153-a73129281e82 none            swap    sw              0       0

Change above to, you can change comment on sda7 to sda8 if desired:

UUID=dc2cd463-e46e-4cbd-b14f-ed811bf6526c   none            swap    sw              0       0

New versions of Ubuntu do not have to have swap partition. They now use a swap file by default. But will use a swap partition if found. Also most desktops do not need /boot as a separate partition. It becomes one more partition you have to manage to make sure it does not fill up. But Ubuntu now only keeps two sets of boot files, so less of an issue than before.

  • Thank you very much for the information,it was very helpful , I created separate /boot partition because I thought it will be helpful while installing a new distro or upgrading the existing one. – A.K. Jul 3 at 16:20
  • I think the boot is still slow after performing the above steps,here is my boot log :bin.disroot.org/?d185bec9ac7632b7#oukE00hFsfadB/… – A.K. Jul 4 at 2:49
  • New log shows same UUID for swap that does not exist. Did you edit fstab & save the changes? – oldfred Jul 4 at 3:35
  • Yes I did that but it looks like it did not work – A.K. Jul 4 at 4:31
  • My laptop booted into kubuntu fast this time when it was on charging,this is the boot.log:pastebin.com/0tPjV6JR but when on power it boots slowly,My fstab:pastebin.com/N8ZysB5z – A.K. Jul 4 at 5:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.