1

Sorry for the terrible post formatting up front I am having to use my phone as I can’t access the internet on my laptop.

So, I am connected to the WiFi, I typed in the password it accepted it and if I check in network manager I have a download speed of 187 mbps, shows a connection of Excellent. So it is getting some sort of signal. But when I open any application or go in my browser I get a “We’re having trouble finding that site” or “offline” status within apps. If I ping ‘8.8.8.8’ I get 100% packet loss and never make it out of my IP. I have reset network manager several times, I’ve flushed the DNS cache. I am not sure what else I can do. Just doesn’t make any sense that I would show a download speed and excellent connection status but not be able to access the internet.

I do not have this issue on this network with my other devices, and do not have this issue on this device on other networks, and haven’t had this issue on this network on this device before today.

Product: ASUS ROG GU501GM (manual download) 07/31/2018

Output for ‘ip route’

Default via 192.168.0.1 dev br0 proto static metric 20425 linkdown 
Default via 10.150.0.1 dev wlol proto dhcp metric 20600
10.150.0.0/17 dev wlol proto kernel scope link src 10.150.119.140 metric 600
169.254.0.0/16 dev br0 scope link metric 1000 linkdown
172.17.0.0/16 dev br0 docker0 proto kernel scope link src 172.17.0.1
192.168.0.0/24 dev br0 proto kernel scope link src 192.168.0.51 metric 425 linkdown
192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1 linkdown

Output for ping 192.168.0.1

Just got icmp_seq=[1-50] Destination Host Unreachable

IPv4 Address: 10.150.119.140 And I am using an Enterprise WPA2 network

Output of ip route 8.8.8.8

8.8.8.8 via 192.168.0.1 dev br0 src 192.168.0.51 uid 1000 cache

I stopped the Docker.service and MySQL.service and still nada. Even reset networkmanager

After the last step if I ran ip route get 8.8.8.8 br0 was still the default.

So I disabled all the virtual controllers and now wlol is showing as the default controller

The output for nmcli device show

output

It is working now!!!! I guess disabling all of my virtual devices and restarting the network manager did it. Thanks for the help guys. I guess enterprise networks don’t like docked much. I guess i will have to deploy when I get home.

  • Basic info includes your release of Ubuntu, can you ping anything on your network? (you won't be able to ping 8.8.8.8 if gateway route isn't defined - is it?) eg. ip route shows a default via to a valid gateway? and can you ping that? – guiverc Jul 2 '19 at 23:30
  • What is the IP address that's being assigned to your network device? Are you using access control lists in your router? – heynnema Jul 2 '19 at 23:33
  • re: "download speed of 187 mbps" is connection speed to your wireless router... not download speed from the Internet. – heynnema Jul 2 '19 at 23:38
  • Sorry for the terrible formatting I literally cannot copy and paste and adding formatting tags is not super easy on a phone. I don’t have internet on my laptop how would I copy/paste? – Brett Plemons Jul 2 '19 at 23:41
  • Can you ping 192.168.0.1? – heynnema Jul 2 '19 at 23:44
1

If you can ping your gateway by running:

sudo ping $(route -n | grep 'UG[ \t]' | awk '{print $2}')

then this is nothing but a DNS issue, and accordingly you can just attempt a quick temporary fix by running

sudo echo 'nameserver 8.8.8.8' > /etc/resolv.conf

This will likely not survive reboot if your resolv.conf is managed by NetworkManager for example but at least you will know right away that it is related to the way the DNS is getting resolved.

  • Yeah it is just saying a ping statement and nothing is happening, which means I am just not getting a connection right? – Brett Plemons Jul 3 '19 at 0:42
  • No! Well, actually in broad terms "yes, your connection is not available/broken" but if you are getting Destination Host Unreachable in the output of the ping command I posted, then that means you are not routing packets to the gateway of wlol. Could you retry the ping command with the interface (wlol) option sudo ping -I wlol $(route -n | grep 'UG[ \t]' | awk '{print $2}') and see if your packets go through – BarBar1234 Jul 3 '19 at 0:55
  • Now I get a ‘ping: SO_BINDTODEVICE: Invalid argument’ – Brett Plemons Jul 3 '19 at 0:59
  • alright, could you post the output of ip route get 8.8.8.8 – BarBar1234 Jul 3 '19 at 1:02
  • thanks, I see what the problem is(or at the very least very likely mighty be), before I post the command to run for the fix, can you post output of sudo nmcli device show . If you need to cover up the names of your wifi connection etcs. just pick an alias and I will use that in the solution accordingly,. – BarBar1234 Jul 3 '19 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.