0

I'm fairly new to Ubuntu, so I'm going to need a little bit of hand holding. I've searched this problem and have tried a few things.

First, some information. I have a dual-booted computer with Windows 10 and Ubuntu 16.04. I have two moniters, one that is connected with a HDMI cable and one that is connected with VGA. My graphics card is a Radeon R9 290/390.

On Windows 10 I have no problems with this, but when I boot up in Ubuntu, the moniters are stuck in mirrored mode, showing me the same thing twice. When I try to change this it doesn't seem to acknowledge the moniters as separate.

I have tried uplugging each moniter and individually both are detected, as I can use either one. But when I plug in the second one, I don't see a new moniter showing up as an option.

I have installed ARandR and it has not helped, it still only detects the one. I have searched this problem and have found others with the same problem, but have yet to find a solution that has worked.

  • I don't have a Ubuntu 16.04 (2016-April release) around which uses the Unity desktop, but this may be handy - ubuntu-manual.org I would pull up the menu and type 'disp' (start of word display) and select display.settings, and ensure you don't have mirror enabled. If you can't find it there, I'd install unity-tweak-tool (has a load of options that aren't available in settings). Sorry it's been too long since I used that release for me to provide more. – guiverc Jul 2 '19 at 12:55
  • I definitely do not have mirror selected. In fact, it's a grayed out option because the system is not even acknowledging there are two montiers (despite content appearing on both). It's basically treating the two screens as one. – Joalro Jul 2 '19 at 13:47
0

I believe that you'll have the best luck having both monitors plugged in at boot, vs plugging and unplugging the live system. I'm not sure it's related, but have you taken a look at the recommended Radeon R9 390 kernel parameters? Do you have any other kernel parameters set? For example, nomodeset will break amdgpu, as noted here.

In doing some research on the Radeon R9 390, I'm seeing people having the best luck using Kernel >=4.16.7. At the time of this post, Ubuntu 16.04 mainline does not have this available. You can see here that by upgrading to 18.04, you'd be able to get on 4.15, which is close but not exactly right. People are also mentioning that amdgpu isn't always being used or loaded properly. You can look at the output of lspci -k, find your graphics card, and make sure that amdgpu is being used.

There are very detailed instructions in this answer walkthrough of options for Ubuntu 16.04 and an explanation for some of the quirks. This post talks about moving from radeon to amdgpu. Some have had success by simply blacklisting radeon.

Which drivers do you have running, and which do you want running? Have you looked at "Additional Drivers", or ubuntu-drivers devices. Can you edit your question and include which drivers are in use? Is upgrading to 18.04 an option for you?

| improve this answer | |
  • So I upgraded to 18.04, I upgraded the kernal to the newest version, and i applied the reccomended kernal parameters. Unfortunately, it seems to have made the problem a bit worse overall. After updating to 18.04, I'm now experiencing quite a bit lof lag in everything I do. Even just moving the mouser around. It got a bit better after updating the kernal, but still now like it was before. And the moniters are still not dual screen as of yet. – Joalro Jul 9 '19 at 1:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.