1

Hello and good afternoon,

I'm fairly new to the Ubuntu ecosystem and i was wondering if there is a way to disable turbo boost on my machine (Bios option not available) i tried following a guide from back in 2015 using msr-tools but did not worked as intended not sure if its even possible but its making my computer fan spinning loudly while I'm just web browsing and i do not use anything intensive that requires a boots on the CPU. My question is: Is there a way to disable turbo boost completely?

3
  • As you are running 14.04 this means 2 things: A) Your question will likely be closed soon and B) You have an old laptop that might need dust cleaned off fan and internal components (like CPU) See: Stop cpu from overheating – WinEunuuchs2Unix Jul 1 '19 at 20:13
  • 1) Please see itsfoss.com/ubuntu-14-04-end-of-life 2) While you are considering upgrading to 16.04, 18.04, or 19.04, please also run sudo lshw | grep product | head -n1 && sudo dmidecode -s bios-release-date && sudo dmidecode -s baseboard-product-name && sudo dmidecode -s baseboard-manufacturer and paste the result into your question after clicking edit. Please do not click on Add Comment as new comments can shove old comments off screen; your information about your PC and installation should all go in the Question so we can all see your findings. – K7AAY Jul 1 '19 at 20:25
  • Sorry im not using 14.04 i'm currently using the latest one which is 18.04.02 – Vilden Jul 1 '19 at 20:34
1

To disable turbo boost (for Intel anyway) use this command:

$ echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
1

Another option is to limit your CPU frequencies to non-turbo boost speeds or even lower. For this purpose I wrote cpuf:

cpuf-demo.gif

Visit the link to copy the script or get more details.

7
  • I attempted to run that command from terminal and got an error message stating command not found. @WinEunuuchs2Unix – Vilden Jul 1 '19 at 20:35
  • @Vilden do not enter the $ prompt that is already displayed. Enter after the prompt: echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo – WinEunuuchs2Unix Jul 1 '19 at 20:39
  • It seems that one worked how would i know if its in fact running? – Vilden Jul 1 '19 at 20:41
  • type cat /sys/devices/system/cpu/intel_pstate/no_turbo and if it returns 1 then turbo is off. It it returns 0 then turbo is on. – WinEunuuchs2Unix Jul 1 '19 at 20:45
  • Great it came back with 1 appreciate the help and support apologize if my thread contained misleading information. @WinEunuuchs2Unix – Vilden Jul 1 '19 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.