5

I have a brand new desktop computer on which I have installed ubuntu 19.04. When I boot the machine, I get the following error:

Jul 1 22:14:42 machinelearning kernel: [ 115.801914] ucsi_ccg 0-0008: failed to reset PPM!
Jul 1 22:14:42 machinelearning kernel: [ 115.803019] ucsi_ccg 0-0008: PPM init failed (-110)

I have managed to start SSH so I can login into the machine via ssh and do what I have to do. However, the GUI does not come up.

Note: I do not remember what I did to get into the GUI but whatever it was, I cannot repeat it and the GUI fails to launch.

I am checking the output of syslog and dmesg and cannot see anything obvious.

Here is my system information. product: Z390 M (Default string)

03/14/2019
Z390 M-CF Gigabyte Technology Co., Ltd.
video card: GeForce GTX 1660 Off | 00000000:01:00.0 Off | N/A | | 34% 39C P0 N/A / N/A | 0MiB / 5943MiB | 0% Default | +-------------------------------+----------------------+----------------------+

The problem appear to be the nvidia drivers. I have installed them based on the nvidia-smi program's suggestion. I am on driver 418 (I am using the proprietary drivers)

Anyone any ideas? Pranav P.S. I also have a system log with me which is the output of the journalctl command. I do not see a way to attach it to the question but am happy to share it.

3
  • Please run sudo lshw | grep product | head -n1 && sudo dmidecode -s bios-release-date && sudo dmidecode -s baseboard-product-name && sudo dmidecode -s baseboard-manufacturer and paste the result into your question after clicking edit. Also please put two space characters after each end of line before you press Enter so what you post formats well. Please do not click on Add Comment as new comments shove old comments off screen; your information about your PC and installation should all go in the Question.
    – K7AAY
    Jul 1 '19 at 17:24
  • startx is the traditional command to restart a GUI from the command line.
    – K7AAY
    Jul 1 '19 at 17:30
  • FWIW, my system (with the same GPU) reports "failed to reset PPM" too. This doesn't prevent it from booting though, only resuming from sleep. See bugs.launchpad.net/ubuntu/+source/linux/+bug/1850238 for more information.
    – Nickolay
    Oct 29 '19 at 1:50
7

I had the same entries in my log. also my computer had a 50 second hang after resuming from suspend during which desktop is black.
ucsi_ccg is a modprobe module for nvidia gpu type-c controller.
as described here this problem appeared in kernel 5.3.x+.
as workaround you can disable this module by creating /etc/modprobe.d/blacklist-nvidia-usb.conf with the blacklist ucsi_ccg string and rebooting your computer.

Note: Blacklisting of this module disables the usb-c connector on the video card.

8
  • I am using nouveau drivers, so should I as well blacklist ucsi_ccg . I am seeing this: [ 7.017666] nvidia-gpu 0000:02:00.3: i2c timeout error e0000000 [ 7.017677] ucsi_ccg 1-0008: i2c_transfer failed -110 [ 7.017678] ucsi_ccg 1-0008: ucsi_ccg_init failed - -110
    – stephanmg
    May 23 at 10:57
  • Blacklisting might then result in not being able to use the USB-C connector for video output, right? :)
    – stephanmg
    May 23 at 12:10
  • 1
    @stephanmg, yes, of course, blacklisting of this module disables the usb-c connector on the video card. I thought it was self-evident. apparently worth adding this to my answer. thank you May 24 at 11:38
  • 1
    @stephanmg, oh, I do not know exactly about that. I do not use this port at all. blacklisting of this port is intended to disable it and prevent syslog error messages and reduce the time the computer wakes from standby. but this article says that usb-c port can indeed be used to connect a monitor. and I think that the proprietary driver is more usable for this. but it is not exactly. only imao May 24 at 23:42
  • 1
    @stephanmg, this guy uses a usb-c port for a portable monitor and he uses a proprietary driver. I don't know if the nouveau driver works with this port, but the proprietary one obviously does. May 24 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.