I installed wine and iTunes. When I run iTunes application starts but it is unusable since I only get black screen. See photo. What to do here?


  • 1
    It's probably picking up your (dark) theme. But everything seems to be there. How is it unusable? FYI, it's just a media player, you dozens of native apps that do the same and better, why are you installing it anyway? It doesn't work in Wine for connecting devices.
    – user880592
    Jul 1, 2019 at 11:59
  • 1
    @Samo you always start with wineHQ to know if a soft will work under wine : appdb.winehq.org/objectManager.php?sClass=version&iId=31322 the answer here is ye....no.
    – tatsu
    Jul 1, 2019 at 15:27
  • I know this is old, but I ran into this problem too. I found this answer: askubuntu.com/a/1063692 but haven't been able to confirm it yet, as I'm not in front of my workstation.
    – auslander
    Sep 9, 2019 at 19:40

1 Answer 1


You have to use iTunes version 12.9.3 and older (32bit). It does not work with newer versions of iTunes (thanks Apple).

I highly recommend using the installation procedure described here.

Works great and there is no need for PlayOnLinux.

  • 1
    Welcome to Ask Ubuntu and thanks for contributing! Could you please edit your answer to include the basic steps from the link you posted, so that the answer will remain valid even if the link is removed or does not work anymore? Sep 28, 2019 at 16:37
  • @No da-mi pace @user3140225 I've followed these steps. When doing the last step, i.e. env WINEPREFIX="/home/david/.wine32" wine /home/david/.wine32/drive_c/Program\ Files/iTunes/iTunes.exe , a blank screen appears. Do you know what might be failing?
    – Dave
    Dec 28, 2019 at 22:39
  • @Dave I'm sorry. I just edited the answer. I don't know much about iTunes in Wine. I would suggest that you post a question about your issue. Hopefully someone will be able to help you! Dec 28, 2019 at 23:34
  • @Dave Did you use use iTunes version 12.9.3 and older the 32bit version? The newer versions give a black screen. you can get it here: filepuma.com/download/itunes_32bit_12.9.3-21404/download Jan 18, 2020 at 10:52
  • 1
    Hi this worked for me thank you! Note of caution, iTunes crashed each time i tried to get logged in. Finally, i ignored the crash dialogue tried logging in anyway. After a number of attempts I was able to download my iTunes library and authorize my Ubuntu machine to play them. In addition I can play playlists saved from my Apple music subscription. But I've been unable to browse the store or find new music (always crashes). Here's a google doc with screenshot of my experience and some more details: docs.google.com/document/d/… May 2, 2020 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.