27

I have been getting this weird error when I put my laptop to sleep and then waking it up after a while. This error forces me to force reboot my computer in order to restart my computer. However wifi and ethernet works fine so I am not sure why this error appears. It usually appears when I put my laptop to sleep and then leave the network then reopening it in my home using my home network.

When I last checked this error is from iwlwifi. Below is the return from the command dmesg | grep iwlwifi

My wifi card is Intel Ac 9560

00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)

command output

3
2

Bug 205513 - iwlwifi: Change log level of "iwlwifi 0000:6f:00.0: BIOS contains WGDS but no WRDS" to "info" has been fixed in Linux kernel.

From the ticket:

We have investigated the issue and it turns out that the reference implementation of the BIOS recommends having WGDS set to NOP values when WRDS is not included. This is what is causing the problem in so many platforms. The error message itself is harmless, so I'm going to reduce the logging level as suggested.

0

I suggest that you ensure that your motherboard firmware is current. Since you have not specified what make or model of machine you are using, I cannot tell you where to find it or what version is current.

0

As was correctly noticed by @pba, that's not critical bug caused by improper logging level. If your Wi-Fi works properly then there's no need to worry. I have got the same Wi-Fi card which runs in Kubuntu 20.04 without issues, despite these messages on boot and shutdown.
If these annoying messages spoil quiet booting and wake-ups then you can adjust console logging level. Run cat /proc/sys/kernel/printk, it will show you four numbers which represent current log levels (mine showed 4 4 1 7). These numbers are explained in details in man 2 syslog. First number represents console_loglevel, we'll decrease it. Create file, say, 20-loglevel.conf in /etc/sysctl.d/ with contents:

kernel.printk = 3 4 1 7

Reboot and see that no more complaints regarding WGDS are shown.

N.B. You'll miss warning messages in console in this case, but more severe errors will be shown. This affects only warnings shown in console — all suspended warning messages are collected and remain in dmesg output.

-1

I had same error,

you can fix it by disable nouveau from the rescue mode with same USB bootable and install graphics card driver and install WiFi driver then update grub, and it will boot normally

2
  • Can you give some details? Mar 20 '20 at 17:02
  • there are 3 steps there but not clear at all
    – Pavlos
    Mar 25 '20 at 13:44
-1

This seems to be a problem with wpa_supplicant that is superceded by iwd that Intel opensourced, further information here. I have tested this with Buster 10, I hope someone of you can test it with latest Ubuntu OS. Below it is illustrated how it works in Debian.

Partial solution

 sudo systemctl restart network-manager

where you can get the WIFI back, without actually solving the problem.

Upgrade from wpa_supplicant to iwd

#OS
#No LSB modules are available.
#Distributor ID:    Debian
#Description:   Debian GNU/Linux 10 (buster)
#Release:   10
#Codename:  buster
#
#KERNEL 
#Linux hhh 5.4.0-0.bpo.4-amd64 #1 SMP Debian 5.4.19-1~bpo10+1 (2020-03-09) x86_64 GNU/Linux


#cat /etc/NetworkManager/NetworkManager.conf
#
#[main]
#plugins=ifupdown,keyfile
#
#[ifupdown]
#managed=false
#
#[wifi]
#wifi.backend=iwd

# Run the below after updating the script above.
#
#iwd instead of wpa_supplicant
systemctl stop NetworkManager.service
systemctl stop NetworkManager.service wpa_supplicant.service
systemctl restart NetworkManager.service
1
-1

your're gonna want to (2) do something like this:

According to the bash man page, $RANDOM is distributed between 0 and 32767; that is, it is an unsigned 15-bit value. Assuming $RANDOM is uniformly distributed, you can create a uniformly-distributed unsigned 30-bit integer as follows:

$(((RANDOM<<15)|RANDOM))
Since your range is not a power of 2, a simple modulo operation will only almost give you a uniform distribution, but with a 30-bit input range and a less-than-16-bit output range, as you have in your case, this should really be close enough:

PORT=$(( ((RANDOM<<15)|RANDOM) % 63001 + 2000 ))
Share
Edit
Follow
1
  • 1
    no thatsawrong idea way . never—mind
    – purd
    Apr 6 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.