7

I installed 19.04 earlier today and spent an hour trying to get audio working. Then audio finally started working after I plugged the speakers into a different spot in the back of my computer.

Then about an hour ago, after audio was working great, everything got quiet and stopped working. I have no idea why this is and don't know how to troubleshoot because this is my first day using linux.

enter image description here

enter image description here enter image description here

It's very strange that there is an "Auto-Mute Mode" in alsamixer that seems to be enabled.

I am sorry, I don't know what I should be looking for or how to diagnose the problem and nothing I have found on the internet has helped so far. Any help is greatly appreciated, thanks

8

Reinstall ALSA and PulseAudio

Try reinstalling ALSA and PulseAudio Manually that must be fix the problem for you.

Open your terminal, and enter the following commands:

sudo apt-get remove --purge alsa-base

sudo apt-get remove --purge pulseaudio

sudo apt-get install alsa-base

sudo apt-get install pulseaudio

sudo alsa force-reload
  • 1
    it worked after I did what you suggested and restarted, thank you – Evan Kim Jul 1 '19 at 11:00
  • 1
    Upgraded 18 to 19. Sound's gone. Applied all above and problem has gone. – Vadim Nov 4 '19 at 13:37
  • this helped me even on Ubuntu 18.04 – Jan Kislinger Jan 13 '20 at 0:10
  • 1
    If you are using ubuntu-gnome-desktop, like I do, you also need to reinstall libcanberra-pulse, otherwise the 'test speakers' functionality in gnome-control-centrum will not work, which will cause even more confusion. I think in my case reinstalling alsa and pulse wasn't needed; I probably needed to poweroff and poweron again, instead of rebooting. – johanv Mar 23 '20 at 10:30
  • This doesn't work for me. I got: gsd-media-keys[2466]: Unable to get default sink and gsd-media-keys[2466]: Unable to get default source errors in my syslog. – Grant Apr 26 '20 at 12:42
3

I don't have enough points yety to comment... have your tried this one? Sometimes my laptop audio goes off and this does the trick

pulseaudio -k 
3

This problem has been going around a while. I have a ASUS UX433FN with a Realtek ALC294 chip. From other threads it sounds like this issue (for dual-boot PC's) seems to be a result of Windows 10's fast boot behavior. I've disabled this feature in Windows 10, doing a full shutdown, and this has seem to fix my problem. Not sure if it's a permanent fix however.

How to disable fast boot on Windows 10

  • 1
    It worked for me. I have a Windows 10 dual boot and my audio would play for only about a second and then fade out, this fixed that. – Robin De Schepper Nov 27 '19 at 14:53
  • @RobinDeSchepper glad to hear it fixed your issue. Would you mind sharing what PC you’re using? – Jon Nov 27 '19 at 19:04
  • It turns out that it was just the full shutdown that solves the issue. Even with FastBoot disabled restarting from Windows causes the sound issues. I'm using an ASUS ZenBook UX533FN – Robin De Schepper Nov 28 '19 at 12:12
  • I upgraded my Ubuntu kernel to the most recent 5.4.0 aswell. – Robin De Schepper Nov 28 '19 at 12:14
  • I can't express how happy I am i found this answer, thank you so much @Jon as the last 2 days have been extremely frustrating for me, trying to debug this problem. I read all of the pulseaudio + alsa troubleshooting guides, as well as kernel bug reports. Nothing worked, not even reinstalling Ubuntu or upgrading to newer kernels. My system: ASUS ZenBook UX334FLC / Ubuntu Focal (20.04) GNU/Linux Kernel: 5.7.9-050709 / Win 10 – petobens Aug 2 '20 at 19:46
1

I tried all the reinstall-PulseAudio-alsa suggestions but finally was able to get mine (a fresh install of 19.10) to work by installing the Gnome Extension "Sound Input & Output Device Chooser".

With that extension you get a drop-down list of places for the speakers. When I picked the one into which the speaker was plugged, I got sound.

Note, my system is a build with no internal speaker and I had to do this the last time I did a clean install and almost every time since I got rid of Windows on this machine and went to Ubuntu. (However, a clean install of Cinnamon Mint did not give me this issue, if I remember correctly that is.)

-1

I like to investigate and always successfully get sound back to my PC... as this solution never fails!!!!

sudo apt remove --purge alsa-base
sudo apt remove --purge pulseaudio
sudo apt install alsa-base
sudo apt install pulseaudio
sudo alsa force-reload
  • This doesn't work for me. I got: gsd-media-keys[2466]: Unable to get default sink and gsd-media-keys[2466]: Unable to get default source errors in my syslog. – Grant Apr 26 '20 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.