1

I have troubles with installing MT4/MT5 under Ubuntu 18.04.2 LTS. I try installing different Wine/Gecko/Mono versions, installing winhttp etc. It always asking me for Proxy server details and the installation is crushing.

I also try changing repositories and any kind of other advise I googled, but still stuck on Proxy request.

Could someone help with advise on the matter? Does MT4/MT5 is supported at all under this Ubuntu release?

Thanks in advance

P.S. Edited: I had been asked to provide specific errors, however after I conduct all suggested solutions listed in the net I don`t get any - it just ask me for a proxy server details, which is a step not needed for MS. From what I found in the net the proxy server details request is the issue itself, it should not happens on the first place.

Briefly I am downloading any of the MT4/MT5 platforms available in the net (from several different brokers), locating them in some folder. Going to that folder by 'cd' command and executing 'wine xxx.exe' command. The program start installing and in one moment it request for proxy server details...

Resolved: If someone has similar problem - check this video - https://www.youtube.com/watch?v=VzgsruDTEuA Download the MT4/MT5 via PlayOnLinux! Then, you could create shortcut for the app - for me it looks like this one: "

!/usr/bin/env xdg-open

[Desktop Entry] Version=1.0 Type=Application Terminal=false Icon[en_US]=gnome-panel-launcher Exec=~/PlayOnLinux's virtual drives/metatrader4/drive_c/Program Files/MetaTrader$ wine terminal.exe Name[en_US]=MT5 Name=MT5 Icon=gnome-panel-launcher "

Finally it is about amendment of the server, ports etc.

Goodluck and cheers!

4
  • By MT4/MT5 I am referring to Metatrader4/Metatrader5. There is one option inside Wine for installing such one, however it is not connected to specific service provider. In more details - Metatrader is a retail trading platform under MS, which is whitelabeled for each broker/investment intermediaries. Basically each broker/intermediary has it`s own fine-tuning on this product. There are some info around the net on the matter, however none of the solutions worked for me. – Vesselin Noushev Jul 1 '19 at 17:08
  • As I already commented - I searched previous solutions and none of them worked... Please provide relevant feedback and comment on the matter only IF you could contribute - Thanks! I would not ask if I knew the answer! Hope it make sense. – Vesselin Noushev Jul 1 '19 at 19:22
  • Hi, I appreciate that you are trying to help, still I believe other peoples had similar issue and they know what I am talking about. No need to get too much involved in a field where someone could solve my query with two lines of text (if possible at all). – Vesselin Noushev Jul 5 '19 at 18:06
  • Issue - Resolved I am updating the Post. Thanks Nmath for trying, it is great they are motivated people around! – Vesselin Noushev Jul 5 '19 at 19:01
0

MT4/ Ubuntu 18.04 LTS/ Wine latest

I've tried with wine-stable and following the video guides on youtube using playonlinux and nothing resolved the proxy error.

Finally what worked for me is below:

  1. Go to official wine page and install latest version for ubuntu.
  2. Click on the exe installer and just install it.

*PlayOnLinux and wine-stable did not worked for me, the proxy error was always there.

0

You can follow this page from Wine official page and it works for me.

https://wiki.winehq.org/Ubuntu

// enable 32-bit architecture

sudo dpkg --add-architecture i386
0

Installing lib32-gnutls worked for me (on another distro). Others have suggested using winetricks to install winhttp

winetricks winhttp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.