Thanks to How do I correctly mount a NTFS partition in /etc/fstab? and cmak.fr both the local NTFS drive and the network samba shares seems to work properly now (recylce bin and file operations works)

the fstab lines for the NTFS drive:

UUID=882679BB2679AAB8 /home/pietro/Storage ntfs-3g defaults,nls=utf8,umask=000,dmask=027,fmask=137,uid=1000,gid=1000,windows_names 0 0

for the samba shares:

// cifs uid=1000,gid=1000,_netdev,credentials=/home/pietro/.smbcred,vers=1.0 0 0

vers=3.1.1 gives me error13 permission denied on the cifs mounts.

I have couple of ntfs drives on a debian server shared with samba.

If i mount them on my ubuntu 18.04 machine (either from terminal or at boot via fstab) nautilus won't copy from those drives more than 1 file at time. If i select more than one file and try to copy them it copies the first one than just "hangs" for the remaining files


Works fine if i use the cp command from terminal or if i use the smb://address/sharename in Nautilus address bar, also works fine if i just browse to the drive from the "other locations".

Atm i solved by sharing the drives with nfs instead. But i'd like to have an username/password on my lan shares.

Any idea what i'm doing wrong? Thanx!

My fstab file:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=a8d1b759-0333-4bf0-92ef-d98f1825ca91 /               ext4    noatime,errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

UUID=882679BB2679AAB8 /home/pietro/Storage    ntfs-3g        auto,user,rw 0 0

# LAN NFS    /home/pietro/Lan/MediaDrive      nfs       rw,soft,intr,noatime,x-gvfs-show

//   /home/pietro/Lan/Bck1   cifs    credentials=/home/pietro/.smbcred   0 0

while to mount it from terminal i used:

mount -t cifs -o username=pietro // /home/pietro/Lan/Bck2
  • I'd try to add the _netdev mount option ie:_netdev,credentials=..... Another idea -that is probably not related is adding uid and gid options uid=1000,gid=1000,_netdev,credentials=.... - There is the option vers for smb version too - Good luck – cmak.fr Jun 30 '19 at 19:12
  • Cheers mate, adding "vers 1.0" seems to do the trick. Doesn't look like i can mark a comment as accepted answer, otherwise i would. Thank you! – zabu Jun 30 '19 at 20:16

I'd try to add the _netdev mount option ie:_netdev,credentials=.....
Another idea -that is probably not related- is adding uid and gid options uid=1000,gid=1000,_netdev,credentials=....There is the option vers for smb version too


The Linux cifs kernel client has been included in the kernel since kernel version 2.5.42. For improved security and performance, SMB3 is the now the default dialect (SMB3.02/SMB3/SMB2.1 dialects are requested by default). CIFS protocol (and other old dialects) can be selected (by specifying "vers=1.0" or "vers=2.02" in the mount options for example). The newest, most secure dialect, SMB3.11 can also be requested (vers=3.1.1).

  • I noticed that adding those extra options now enabled the trash bin on the mounted drives aswell. On the 2nd NTFS drive (the storage drive shared with the win10 dual boot) on the same machine it still just asks me if i'm sure i want to permanently delete them. UUID=882679BB2679AAB8 /home/pietro/Storage ntfs-3g auto,user,rw 0 0 is the fstab entry for the drive – zabu Jul 1 '19 at 7:48
  • Figured it out thanks to askubuntu.com/questions/113733/…. Thanks again! – zabu Jul 1 '19 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.