9

I'm using Ubuntu 19.04. I'm aware of this question, but when I try to install via

sudo dpkg -i viber.deb

I get this:

Selecting previously unselected package viber.
(Reading database ... 206700 files and directories currently installed.)
Preparing to unpack viber.deb ...
Unpacking viber (10.3.0.37) ...
dpkg: dependency problems prevent configuration of viber:
 viber depends on libssl1.0.0; however:
  Package libssl1.0.0 is not installed.

dpkg: error processing package viber (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 viber

I have tried the Viber Unofficial snap, but I ran into the huge screen rez and I don't know how to fix that either.

10

for all the people out there who do not like to install the flatpak version and want to stick to the deb version, there is another way: since new versions of Ubuntu are shipped with libssl1.1 or have this package in their repositories, viber.deb can be tinkered to state libssl1.1 as a dependency.

I cannot guarantee 100% that all dependencies are met, but retro-compatibility should function. I have also applied this method and so far I do not have any problem on Xubuntu 19.10.

Here is a short walkthrough:

  1. Ensure that libssl1.1 is installed:

    sudo apt install libssl1.1
    

    Note: if a newer version of libssl is available, this should be used further on on step 4.

  2. Download viber.deb from the Viber webpage and copy it to a temp folder. I have used /home/<user>/temp for this.

  3. Now we need to make some changes to the package, following this guide.

    mkdir viber
    cd viber 
    ar x ../viber.deb
    tar xzf control.tar.gz
    

    Line by line this does the following:

    • Creates a new folder named viber.
    • Moves to the new folder.
    • Unpacks viber.deb.
    • Unpacks control.tar.gz.
  4. Now we need to change dependencies:

    • Open the control file with a text editor.
    • Change on line 6: libssl1.0.0 to libssl1.1.

      Note: in case of newer version of libssl use the new version (see step 1!).

    • Save the file and exit.
  5. Repackage the .deb file.

    tar --ignore-failed-read -cvzf control.tar.gz {post,pre}{inst,rm} md5sums control
    ar rcs viber-new.deb debian-binary control.tar.gz data.tar.gz
    
  6. Install the new deb:

    sudo dpkg -i viber-new.deb
    

Voila!

| improve this answer | |
  • 3
    this works perfectly. Only thing is repackaging command is referencing data.tar.gz but the deb file I downloaded required it to be data.tar.xz so ar rcs viber-new.deb debian-binary control.tar.gz data.tar.xz works perfectly – Samar May 11 at 0:34
8

Viber installation on Ubuntu 19.04, 19.10, 20.04

Download libssl1.0.0 deb package from here and install it before installing viber (18.04 repository still contains it).

You could install this package by executing the next commands:

wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb
sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb

sudo apt install ./viber.deb

If you've encountered some viber launching issues (viber starts and crashes), then try to change display manager (to gdm3, for example):

sudo dpkg-reconfigure gdm3
| improve this answer | |
  • Doesn't work for 19.04 as one of the commenters says. – Svetlana Belkin Aug 14 '19 at 13:38
  • 1
    executing the commands solved the libssl nightmare for me. Thanks! (20.04) – michaelmixon Apr 30 at 9:45
4

Viber's Flatpak solves the issue:

To Install:

flatpak install flathub com.viber.Viber

To Run:

flatpak run com.viber.Viber
| improve this answer | |
2

The only way I found working for Ubuntu is here: https://linuxconfig.org/how-to-install-viber-on-ubuntu-20-04-focal-fossa-linux

This installs the official Viber.

BUT make sure to fix the package version from 6.2 to 5.3!

Here the fixed commands:

$ wget -O ~/viber.deb https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
$ sudo apt install gdebi-core
$ wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb
$ sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb 
$ sudo gdebi ~/viber.deb
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.