0

My current setup which has worked for a while now is to run a Win 10 laptop with an Intel 530 GPU. On this I installed VMWare workstation player v12 and ran an Ubuntu 18.04 installation.

Two weeks ago there was a Win 10 update and since then the graphics on the Ubuntu installation no longer seem to work. The VM boots and the initial graphics loads with a very faint Ubuntu splash screen then stops, not allowing me to login to the desktop.

I've upgraded the VMWare player to v15.

I've looked at various threads on this site and others and I've done the following:

run apt install haveged

run systemctl enable haveged

run apt update

run apd upgrade

run apt-get install xserver-xorg-video-intel # run to make sure I've got the latest intel drivers (which it said I already did).

Made sure all of the xorg packages are up-to-date (which the system said they were).

I've logged in through the grub advanced menu to the default graphics and I get a message saying screen, graphics card and input device settings could not be detected correctly.

None of the above have worked. Even if I just try to run a firefox session from the command line I get Unable to init server: Broadway display type not supported.

Does anyone else have any ideas that I could try? I'd hate to lose this guest OS as it's my go to for a secure desktop to do banking etc and has a lot of stored information.

0

This sounds just like what I am seeing, also Win 10 host, Ubuntu 18.04 guest, and VMWare Workstation Pro v12. Mine seemed to start after an Ubuntu update.

This question described the problem I saw

And the answer that worked for me was to set WaylandEnable=false as described here

| improve this answer | |
  • You, sir, are an absolute star. I've been wrestling with this for a couple of weeks but haven't seen anything about the WaylandEnable option. I followed the instructions in the post you linked and it's working fine now. Thank you so much for your help. – Steve Davies Jul 1 '19 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.