5

After doing a dist-upgrade yesterday evening the open-vm-tools-desktop are no longer working correctly. Which means, I can't resize to fullscreen. Trying to do so ends in a black screen. Taking a look into the different Log-Files and Tools I've found this error multiple times:

modprobe: ERROR: could not insert 'vmwgfx': Invalid argument

Trying to add the module vmgfx by hand to modprobe blacklist

sudo modprobe --use-blacklist vmwgfx

also ends in the above mentioned error.

Taking a look via

sudo service open-vm-tools status

Also shows the following error:

Process: 3930 ExecStartPre=/sbin/modprobe vmwgfx (code=exited, status=1/FAILURE)

I already googled and found some posts and issues (https://github.com/vmware/open-vm-tools/issues/214) mentioning to add:

After=graphical.target
After=display-manager.service

to the Unit section of /lib/systemd/system/open-vm-tools.service but with no success.

Also sudo apt remove --purge open-vm-tools-desktop && sudo apt autoremove --purge && sudo apt install open-vm-tools-desktop did not do the trick.

During boot I get to see this error message quite at the beginning of the output. enter image description here

Running the suggested command systemctl status systemd-modules-load.service shows the following output which also includes the error from above.

enter image description here


Output of /var/log/apt/history.log from yesterday evening:

Start-Date: 2019-06-28  22:12:11
Commandline: apt dist-upgrade
Requested-By: **** (1000)
Install: linux-modules-extra-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic), linux-modules-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic), linux-headers-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic), linux-headers-4.15.0-54:amd64 (4.15.0-54.58, automatic), linux-image-4.15.0-54-generic:amd64 (4.15.0-54.58, automatic)
Upgrade: gstreamer1.0-alsa:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), linux-headers-generic:amd64 (4.15.0.52.54, 4.15.0.54.56), linux-libc-dev:amd64 (4.15.0-52.56, 4.15.0-54.58), xserver-common:amd64 (2:1.19.6-1ubuntu4.2, 2:1.19.6-1ubuntu4.3), gstreamer1.0-plugins-base-apps:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), xserver-xorg-core:amd64 (2:1.19.6-1ubuntu4.2, 2:1.19.6-1ubuntu4.3), gstreamer1.0-tools:amd64 (1.14.1-1~ubuntu18.04.2, 1.14.4-1~ubuntu18.04.1), linux-image-generic:amd64 (4.15.0.52.54, 4.15.0.54.56), gstreamer1.0-plugins-good:amd64 (1.14.1-1ubuntu1~ubuntu18.04.1, 1.14.4-1ubuntu1~ubuntu18.04.1), xserver-xorg-legacy:amd64 (2:1.19.6-1ubuntu4.2, 2:1.19.6-1ubuntu4.3), gstreamer1.0-plugins-base:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), libgstreamer-plugins-good1.0-0:amd64 (1.14.1-1ubuntu1~ubuntu18.04.1, 1.14.4-1ubuntu1~ubuntu18.04.1), gstreamer1.0-pulseaudio:amd64 (1.14.1-1ubuntu1~ubuntu18.04.1, 1.14.4-1ubuntu1~ubuntu18.04.1), xserver-xephyr:amd64 (2:1.19.6-1ubuntu4.2, 2:1.19.6-1ubuntu4.3), gstreamer1.0-gtk3:amd64 (1.14.1-1ubuntu1~ubuntu18.04.1, 1.14.4-1ubuntu1~ubuntu18.04.1), pgadmin4-doc:amd64 (4.8-2.pgdg18.04+1, 4.8-3.pgdg18.04+1), libgstreamer-gl1.0-0:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), libgstreamer-plugins-base1.0-0:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), xwayland:amd64 (2:1.19.6-1ubuntu4.2, 2:1.19.6-1ubuntu4.3), gstreamer1.0-x:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), gir1.2-gst-plugins-base-1.0:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1), google-cloud-sdk:amd64 (251.0.0-0, 252.0.0-0), gir1.2-gstreamer-1.0:amd64 (1.14.1-1~ubuntu18.04.2, 1.14.4-1~ubuntu18.04.1), kubectl:amd64 (1.14.3-00, 1.15.0-00), pgadmin4:amd64 (4.8-2.pgdg18.04+1, 4.8-3.pgdg18.04+1), libgstreamer1.0-0:amd64 (1.14.1-1~ubuntu18.04.2, 1.14.4-1~ubuntu18.04.1), linux-generic:amd64 (4.15.0.52.54, 4.15.0.54.56), pgadmin4-common:amd64 (4.8-2.pgdg18.04+1, 4.8-3.pgdg18.04+1), gstreamer1.0-gl:amd64 (1.14.1-1ubuntu1~ubuntu18.04.2, 1.14.4-1ubuntu1.1~ubuntu18.04.1)
End-Date: 2019-06-28  22:14:05

Output of lsb_release -a:

Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:    18.04
Codename:   bionic

I'm not finally sure why this happened, but as far as I understood different topics on the internet it's a mismatch with the used kernel version ? Does anyone know if there is a possibility to fix such an issue without reinstalling the whole system ?

2
  • 1
    cat /etc/modprobe.d/vmwgfx-fbdev.conf
    – nobody
    Jun 29 '19 at 11:01
  • cat: /etc/modprobe.d/vmwgfx-fbdev.conf: No such file or directory Jun 29 '19 at 11:06
0
sudo apt install --reinstall -o Dpkg::Options::=--force-confnew xserver-xorg-video-vmware
4
  • No success. Also after a restart still no change. Everything still as mentioned above. Jun 29 '19 at 11:17
  • update the initrid update-initramfs -uv -k $(uname -r) this conf is also there.
    – nobody
    Jun 29 '19 at 11:25
  • Still does not do the trick. The config you mentioned in your comment above is still not there and I still don't get any change in behavior or error outputs. Everything still the same. Output of uname -r is 4.15.0-54-generic. Updated my answer with two additionals Printscreens showing some error output. Jun 29 '19 at 11:40
  • 1
    if you wish, we can chitchat. chat.stackexchange.com/rooms/95522/…
    – nobody
    Jun 29 '19 at 11:49
0

Anybody with a solution here ? I have the same problem since updating my packages for Ubuntu 18.04.2 LTS VM on VmWare Fusion 11.1.0.

[Update] I have solved my issue now by activating the "bionic-proposed" flag in the application & update tool. There were no installation packages related to open-vmware-tools but new kernel packages, which I installed.

I had running Kernel 4.15.0-54-generic before, now it is:

uname -a
Linux schnd-1804-vm 4.15.0-55-generic #60-Ubuntu SMP Tue Jul 2 18:22:20 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I don't know if this is an issue related with the state of my previous kernel or with the kernel module vmwgfx which returned EINVAL. But all is fine now again.

[Update2] This option should not be activated for the casual Ubuntu user, as it might pull in not yet fully tested dependencies. Use as a last resort if no other means work and deactivate the option again after your setup starts working.

4
  • This is not an answer to the question asked and so should not be posted as such. If you have a different question, you can ask it by clicking Ask Question.
    – CentaurusA
    Jul 10 '19 at 12:47
  • Changed to be an answer to the question.
    – lumpidu
    Jul 10 '19 at 13:52
  • You should never run from the Proposed repository for kernels. Because that tends to pull in a lot of other software too not yet fit for inclusion/use.
    – Thomas Ward
    Jul 10 '19 at 14:11
  • Thanks for downvoting my answer, but this is the difference for me of not been able to do my payed work or having the option to earn money again, because I could not log in into my virtual machine. There might be others that are affected by this obvious incompatibility and I am willing to take this risk as there are no other answers here that can solve it in a political correct manner. And as a reminder: this option is available in section "Developer". Guess what? That is exactly my audience.
    – lumpidu
    Jul 11 '19 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.