0

I'm following this tutorial: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-on-ubuntu-16-04

I've done all up to Step 3 - installed and set up vncserver. I have two problems: first, after I run vncserver it creates a numbered session. I can try to kill it by using vncserver -kill :1``` but it might not entirely kill it, so later if I typevncserver -list``` it would print Warning: droplet:1 is taken because of /tmp/.X1-lock. Remove this file if there is no X server droplet:1. If I try to kill it again I would get Can't find file /root/.vnc/droplet:3.pid.You'll have to kill the Xtightvnc process manually. Those sessions seem to accumulate and consume memory - at one point I got a out of memory error.

Second problem is that I can't get it to run on port 5901. I tried using vncserver and then sudo netstat -peanut and I don't see port 5901 in the list.

I'm at the end of my rope here, any help is welcomed.

  • What are the exact commands you are using to start the vncserver and the vnc viewer? – ubfan1 Jun 28 '19 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.