i'm trying to change from runlevel 5 to runlevel 3 by running sudo init 3 command.
for some reason it doesn't do anything anymore.
the weird thing is that if i run the command runlevel it shows me that i'm at level 3.
tried to run init 5 and then init 3 and still nothing.

does anybody knows how to fix it?

  • What exactly do you expect to happen? – Karlson Mar 23 '12 at 20:05

From the manpages:

   Runlevels are a concept from UNIX(R)  System  V  used  by  the  init(8)
   daemon  or other system initialisation system to define modes of system
   The Upstart init(8) daemon has no  native  concepts  of  runlevel,  and
   unlike  the  System  V  daemon,  makes  no attempt to keep track of the
   current runlevel.

Ubuntu and other modern Linux distributions have replaced System V init with Upstart:

Upstart is an event-based replacement for the /sbin/init daemon which handles starting of tasks and services during boot, stopping them during shutdown and supervising them while the system is running.

If you must switch to what is now closest to runlevel 3 do it by stopping your gdm or lightdm service.

| improve this answer | |

Hold shift at boot, select recovery nmode then select root, you can now switch between runlevels from there easily.

| improve this answer | |
  • Hi there - your account is unregistered - however, there is a similar account here (askubuntu.com/users/9962/actionparsnip) - do you require your unregistered account merged with the registered account? – fossfreedom Mar 24 '12 at 22:37
  • 1
    i think his question is not how best to switch runlevels... instead he wants to know why switching runlevels does not have the desired effect in newer versions of ubuntu... +1 for the tip... :-) – user1055604 Mar 25 '12 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.