0

A while ago my terminal stopped coming up when I pressed ctrl-alt-T. Then today the terminal stopped coming up when I click on the terminanl app on the dock. I use ubuntu 18.04, a lot of python and jupyter-lab.

The only way that I know of to open terminal anymore is going to Files, and right clicking somewhere and choosing 'open in terminal'. For some reason this still works.

Why is this and how can i recover all the other ways to open terminal?

On a side note, I get an error when trying to do sudo apt-get update.

[sudo] password for user: 
Ign:1 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic InRelease     
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Err:3 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release       
  404  Not Found [IP: 91.189.95.83 80]
Hit:4 http://au.archive.ubuntu.com/ubuntu bionic InRelease                     
Hit:5 http://au.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:6 http://au.archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:7 http://au.archive.ubuntu.com/ubuntu bionic/main Translation-en_CA [430 kB]
Get:8 http://au.archive.ubuntu.com/ubuntu bionic/universe Translation-en_CA [4,118 kB]
Reading package lists... Done                                                  
E: The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Theres a red error bar on the top right hand side of screen that always says "A problem occurred when checking for the updates".

I don't know if this is related.

  • 1
    The 'trusty-media' PPA you list supported only 14.04/trusty, where as 18.04 is named 'bionic'. That PPA should be removed. The Ctrl+Alt+T is a keyboard shortcut, so you may have removed for some reason, so adding it back as a shortcut to open the terminal should fix your issue (assuming that's what you did; it could also be you removed the terminal package it called, and the 'open in terminal' you mention opens another. Xubuntu uses xfce4-terminal, where gnome-terminal is default for Unity/Gnome. If you made changes to your system's [default] python things can be adversely effected. – guiverc Jun 28 at 15:00
  • The PPA error is easy to solve, just remove thw repository (it doesn't support your release, as if its name wasn't clue enough). Whether or not it will solve the terminal problem I don't know but I wouldn't count on it. – GabrielaGarcia Jun 28 at 15:02
  • For bionic you have to add sudo add-apt-repository ppa:mc3man/bionic-media.Before erase sudo add-apt-repository -r ppa.launchpad.net/mc3man/trusty-media – nobody Jun 28 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.