2

My headset microphone only works when I choose option "Microphone" on Sound Settings, but when I select this options I can hear a "click" in the headset speaker and it stops working.

Sound Settings

When I change to other input option, speakers works fine again.

Already tried with several headset, even with the simple ones that comes with smartphones, doesn't work either.

My notebook is a Dell Vostro running Ubuntu 18.04

head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC3204
cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xa52a0000 irq 157
lspci |grep Audio
00:1f.3 Audio device: Intel Corporation Device 9dc8 (rev 30)
2
  • Do you know which audio chipset you have? or which machine you are running into this issue on? – Synchro Jun 27 '19 at 19:22
  • Just edited my question to insert this information. – Gabriel Piassetta Jun 27 '19 at 19:59
0

I don't know if you ever figured this out, but I just ran into the same problem using Pop!_OS 20.10 - basically Ubuntu.

I just killed pulseaudio and restarted it to get stereo sound and mic back. I did it with:

$ pulseaudio -k
$ pulseaudio -D

My system had another symptom in that my headphones were only playing mono sound. I don't know if that was your experience as well.

I don't know how long this will fix it, but it seems to have worked this time. I found my solution here: https://appuals.com/how-to-fix-pulseaudio-issues-in-linux/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.