0

Trying to get something working on a SFF box for CNC control. Can't get wireless to work under Bodhi 5.0.0 or Lubuntu 18.04, or Lubuntu 19.04. (Hardware is a LogicSupply AG150)

I've verified that I'm using the latest driver version for the hardware from https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

The only other instance of the exact same problem I found is for completely different hardware/os. https://community.nxp.com/thread/336121

I've also tried the 'well-known work-around' from https://askubuntu.com/a/462410/970126 of

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Here's the actual problem as shown by dmesg (last 3 lines):

[   44.072759] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
[   44.139621] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   44.566744] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
[   46.224888] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   46.238035] iwlwifi 0000:02:00.0: Radio type=0x2-0x1-0x0
[   51.424070] iwlwifi 0000:02:00.0: Failed to load firmware chunk!
[   51.424085] iwlwifi 0000:02:00.0: iwlwifi transaction failed, dumping registers
[   51.424094] iwlwifi 0000:02:00.0: iwlwifi device config registers:
[   51.424152] iwlwifi 0000:02:00.0: 00000000: 088e8086 00100406 02800024 00000010 40500004 00000000 00000000 00000000
[   51.424165] iwlwifi 0000:02:00.0: 00000020: 00000000 00000000 00000000 40608086 00000000 000000c8 00000000 0000010a
[   51.424173] iwlwifi 0000:02:00.0: iwlwifi device memory mapped registers:
[   51.424228] iwlwifi 0000:02:00.0: 00000000: 00484b00 00000040 20000000 08000000 00000000 00000000 00000030 00000000
[   51.424239] iwlwifi 0000:02:00.0: 00000020: 00000009 080003c5 000000b0 00000000 90000801 00030001 80008040 00080044
[   51.424251] iwlwifi 0000:02:00.0: iwlwifi device AER capability structure:
[   51.424288] iwlwifi 0000:02:00.0: 00000000: 14010001 00004000 00000000 00062011 00002000 00002000 0000000e 00000000
[   51.424297] iwlwifi 0000:02:00.0: 00000020: 00000000 00000000 00000000
[   51.424305] iwlwifi 0000:02:00.0: iwlwifi parent port (0000:00:1c.3) config registers:
[   51.424339] iwlwifi 0000:00:1c.3: 00000000: 27d68086 00100007 06040002 00810010 00000000 00000000 00020200 20004040
[   51.424351] iwlwifi 0000:00:1c.3: 00000020: 40504050 40c140b1 00000000 00000000 00000000 00000040 00000000 000404ff
[   51.424364] iwlwifi 0000:02:00.0: Could not load the [0] uCode section
[   51.436122] iwlwifi 0000:02:00.0: Failed to run INIT ucode: -110
[   51.436155] iwlwifi 0000:02:00.0: Unable to initialize device.

Here are the wireless-info logs from all 3 installs.

Where do I look or what do I try next to get this working?

2

I believe that there are but three possibilities. First, does the required firmware actually exist on your system? According to Intel's own site, the needed firmware is iwlwifi-6000g2b-6.ucode. Please see: https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html

Please check your system:

cd /lib/firmware && ls | grep iwlwifi-6000g2b-6.ucode

Does the file exist?

The second possibility is that the file is somehow corrupted. Let's check:

md5sum iwlwifi-6000g2b-6.ucode

My system returns 1f1763dfd472a487c3d61eac0a12b766. If yours returns the same, then I doubt that the firmware is corrupted.

In fact, I doubt that, on three installations across two different Linux distributions, that the firmware is always missing and/or always corrupted. That leads to the third possibility, That the hardware, that is, the card itself, is either not seated properly in its slot or else is electrically defective.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.