1

I am not very familiar with Ubuntu, but I am desperately trying to use Balzegraph on my Ubuntu (Ubuntu 18.04 LTS Bionic) VM which has a GUI.

On the Blazegraph website, it says to just use its blazegraph.jar file with a command it has provided: from blazegraph website

However, this Jar file does run on a Windows machine, but not on my Ubuntu VM!

When I tried downloading the file using my Ubuntu machine, it downloaded a "blazegraph.rpm" file. After updating the packages, I used sudo alien rpmpackage.rpm and then sudo dpkg -i rpmpackage.deb but I got this error:

dpkg: error processing package blazegraph-rpm (--configure): installed blazegraph-rpm package post-installation script subprocess returned error exit status 1 Errors were encountered while processing: blazegraph-rpm E: Sub-process /usr/bin/dpkg returned an error code (1)

I then tried to rectify the issue re-configuring the package using sudo dpkg --configure -aand installing forcefully with sudo apt-get install -fbut I had no luck!

I also looked at this solution but couldn't find or match the file they mentioned since there was 4 Blazegraph files, but not a blazegraph-rpm!

I wonder if anyone can help me with this?

0

This should point you in the right direction.

Packages often come with pre- and post-install scripts. These integrate the package into the host system and are usually distribution-specific. AFAIK, (by default) alien does not setup these files to be run when the package is installed because they usually break things when run on another distro. This appears to be what you're running into. Did you specify -c or --scripts in the alien command?

Since your app is a jar file, it probably doesn't need to be installed. It will just run. But, the install may try to install needed dependencies and add it to your launcher menu. Things you will need to do manually in this situation.

What you need to do is read through the scripts that come with the package and figure out how to manually do what they do on your system.

I downloaded blazegraph.jar from https://sourceforge.net/projects/bigdata/

and was able to run it, using the command you linked to above, but it promptly died on an internal error.

I poked around some more and found a support list where you can sign up and ask questions at https://sourceforge.net/projects/bigdata/lists/bigdata-developers

It looks like it's very quiet. However, there do appear to be project updates in 2019 on their GitHub page, so someone may be there to help you.

I just reviewed the output from running the program and it lists licenses for some 30 dependencies. You would probably have to pre-install whichever of those are not already built into the jar itself.

  • Thanks for your input. I have moved to Fuseki since I was desperate to get my codes going, but I really appreciate your help. Of course, I did send them a post on their GitHub page and got some help but it was not helpful probably because I am not familiar with Linux. I have visited their Sourceforge page too. In addition sorry that I couldn't +1 you post. It says I have to have at least 15 rep. to be able to do that! Thanks again :) – RFNO Jul 5 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.