0

I'm new to this, so please forgive the lack of technical ability.

I downloaded ubuntu live server 18.04.2, and successfully created a bootable USB stick.

I have two brand new WD Red 3TB drives, with the goal of creating a RAID 1 setup server with remote access.

I am running an old Dell 2.8ghz dual core. 6G memory (4x 2G, system reads only 6G)

I successfully got through manual partition as such: 10g /boot (drive 1) 16g swap (drive 1) 2.6T Raid 1, divided as 40g /; 2.4T /home

It installs, and begins a reboot. I remove the thumb drive to begin reboot, but no bootable drive is found.

BIOS is configured to read for hard drives to boot.

When I try and reboot with the thumb drive back in, I come to the installer screen, but the hard drives are back to "unused" format.

Any advice?

  • Hi Matt! Welcome to AskUbuntu! Firstly, considering this is BIOS, your boot partition has to be marked as bootable in the disk partition table (see fdisk). Secondly, RAID is tricky and the installer doesn't handle it very well. You have to make sure that the RAID is fully synchronised after the disk-management page but before continuing on to the install. This involves dropping to a command prompt and calling cat /proc/mdstat repeatedly. Rebooting too early can result in an unrcoverable unsynchronised RAID. – tu-Reinstate Monica-dor duh Jun 27 '19 at 3:47
  • That makes sense, thank you for the quick response. As I am installing this from a bootable USB, is there a way to access the command prompt/terminal from the GUI? Also, any guidance for the command to make the /boot recognized as such from the BIOS? – Matt Jun 27 '19 at 3:59
  • I followed the advice of using the full image, instead of Live. It seemed to work with the full install, but again no luck on reboot. I chose the disk for the boot loader during install, now how would I go about marking it? – Matt Jun 27 '19 at 6:38
0

I had this problem with my old AMD Phenom board when setting up my home server. There's some bug with the live installer for 18.04 where it went through the installation process, but never actually made the drive bootable. What's weird is it worked fine in a virtual machine for testing, but not on my real hardware. Try downloading the full fat installation image instead of the live one. It worked on mine when the live installer didn't.

Just go to the download page and under the server section click the "traditional installer" link.

enter image description here

  • 1
    "What's weird is it worked fine in a virtual machine for testing" Yes, that's because your virtual environment is more consistent (possibly even open source!) than a manufacturer's proprietary buggy BIOS. :-p – tu-Reinstate Monica-dor duh Jun 27 '19 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.