0

Do anyone know how to resolve this issue?

Service 'maas-dhcpd' is not on, it will be started.
Service 'bind9' failed to start. Its current state is 'dead' and 'Result: exit-code'.
Reloading BIND failed (is it running?): Command `rndc -c /etc/bind/maas/rndc.conf.maas reload` returned non-zero exit status 1:#012rndc: connect failed: 127.0.0.1#954: connection refused

I have 2 subnets, one bridge and one local network with 3 interfaces eth0, eth1, br1 my network interfaces:

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
dns-nameservers x.x.1.1
dns-search maas

# The primary network interface
auto eth0
iface eth0 inet static
address x.x.1.2
netmask 255.255.255.0
gateway x.x.1.1
dns-nameservers x.x.1.1 8.8.8.8 8.8.4.4
mtu 1500

auto eth1
iface eth1 inet manual
mtu 1500

auto br1
iface br1 inet static
address x.x.30.1
netmask 255.255.255.0
   bridge_ports eth1
   bridge_stp off
   bridge_fd 0
   bridge_maxwait 0

Maas subnet configuration from UI: Managed allocation is disabled for below:

Name x.x.1.0/24
CIDR x.x.1.0/24
Gateway IP x.x.1.2
DNS 172.16.1.1

Managed allocation is enabled for below:

Name x.x.30.0/24
CIDR x.x.30.0/24
Gateway IP x.x.30.1
DNS x.x.1.1

Running sudo rndc -c /etc/bind/maas/rndc.conf.maas reload ends up with:

rndc: connect failed: 127.0.0.1#954: connection refused

I'm not sure what am I missing, this MaaS version is 2.5

Additional note: for while i'm investigating, I noticed that there are duplicated entries in named.conf.maas, if I fix the duplicate manually, it will be autogenerated again and back to the same issue.

/etc/bind/maas/named.conf.maas:92: zone 'x.y.z.in-addr.arpa': already exists previous definition: /etc/bind/maas/named.conf.maas:56

The above issue is related to https://discourse.maas.io/t/facing-old-bug-lp-1683047-with-maas-2-5-stable-bind9-fails-to-start-duplicated-entry/314

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.