0

I setup up a bond with 2 devices in ubuntu 18.04.

It looks like the bond0 is comming and i can ping it, but the physical interfaces got an IP-address from my DHCP-Server, too.

IP-address of interface enp3s0 and bond0 are in the same scope, and that ends in trouble.

Any ideas whats wrong with my config?

My netplan-config:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp2s0:
     dhcp4: false
     dhcp6: false
    enp3s0:
     dhcp4: false
     dhcp6: false


  bonds:
    bond0:
      interfaces:
       - enp2s0
       - enp3s0
      parameters:
        mode: 0
      addresses: [192.168.88.8/24]
      gateway4: 192.168.88.1
      nameservers:
        search: [lan]
        addresses: [127.0.0.1, 192.168.88.1]

after appling the config the ip-addresse on the devices look like this:

bond0: flags=5187<UP,BROADCAST,RUNNING,MASTER,MULTICAST>  mtu 1500
        inet **192.168.88.8**  netmask 255.255.255.0  broadcast 192.168.88.255
        inet6 fe80::6478:e7ff:fec9:3af4  prefixlen 64  scopeid 0x20<link>
        inet6 2001:16b8:42d:e200:81e2:eb92:f8ac:5c22  prefixlen 64  scopeid 0x0<global>
        inet6 2001:16b8:42d:e200:6478:e7ff:fec9:xxxx prefixlen 64  scopeid 0x0<global>
        ether 66:78:e7:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 16003  bytes 2905996 (2.9 MB)
        RX errors 0  dropped 1280  overruns 0  frame 0
        TX packets 12699  bytes 2546657 (2.5 MB)
        TX errors 0  dropped 18 overruns 0  carrier 0  collisions 0

enp2s0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        inet 169.254.229.33  netmask 255.255.0.0  broadcast 169.254.255.255
        ether 66:78:e7:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 13819  bytes 2678515 (2.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 11456  bytes 2425479 (2.4 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        inet **192.168.88.193**  netmask 255.255.255.0  broadcast 192.168.88.255
        ether 66:78:e7:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 2184  bytes 227481 (227.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1243  bytes 121178 (121.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 2793  bytes 302214 (302.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2793  bytes 302214 (302.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@gemini:/etc/netplan# netplan --debug generate
DEBUG:command generate: running ['/lib/netplan/generate']
** (generate:15612): DEBUG: 19:42:50.224: Processing input file /etc/netplan/01-netcfg.yaml..
** (generate:15612): DEBUG: 19:42:50.227: starting new processing pass
** (generate:15612): DEBUG: 19:42:50.227: enp3s0: setting default backend to 1
** (generate:15612): DEBUG: 19:42:50.227: Configuration is valid
** (generate:15612): DEBUG: 19:42:50.227: enp2s0: setting default backend to 1
** (generate:15612): DEBUG: 19:42:50.227: Configuration is valid
** (generate:15612): DEBUG: 19:42:50.227: bond0: setting default backend to 1
** (generate:15612): DEBUG: 19:42:50.227: Configuration is valid
** (generate:15612): DEBUG: 19:42:50.227: Generating output files..
** (generate:15612): DEBUG: 19:42:50.228: NetworkManager: definition enp2s0 is not for us (backend 1)
** (generate:15612): DEBUG: 19:42:50.228: NetworkManager: definition enp3s0 is not for us (backend 1)
** (generate:15612): DEBUG: 19:42:50.228: NetworkManager: definition bond0 is not for us (backend 1)

root@gemini:/mnt/extdisk/B# sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 06
       serial: 66:78:e7:c9:3a:f4
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=169.254.229.33 latency=0 link=yes multicast=yes port=MII slave=yes speed=1Gbit/s
       resources: irq:17 ioport:e000(size=256) memory:b0804000-b0804fff memory:b0800000-b0803fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 11
       serial: 66:78:e7:c9:3a:f4
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII slave=yes speed=10Mbit/s
       resources: irq:18 ioport:d000(size=256) memory:b0704000-b0704fff memory:b0700000-b0703fff
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: bond0
       serial: 66:78:e7:c9:3a:f4
       size: 1Gbit/s
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=bonding driverversion=3.7.1 duplex=full firmware=2 ip=192.168.88.8 link=yes master=yes multicast=yes speed=1Gbit/s

alternative config

root@gemini:/etc/netplan# cat 01-netcfg.yaml
network:
   bonds:
       bond0:
           addresses: [192.168.88.8/24]
           gateway4: 192.168.88.1
           nameservers:
              addresses: [127.0.0.1, 192.168.88.1]
           interfaces:
              - enp2s0
              - enp3s0
   ethernets:
       enp2s0:
         dhcp4:false
       enp3s0:
         dhcp4:false
root@gemini:/etc/netplan# netplan apply
/etc/netplan/01-netcfg.yaml:10:17: Error in network definition: bond0: interface 'enp3s0' is not defined
              - enp3s0
                ^
root@gemini:/etc/netplan#
0

As per https://netplan.io/reference and https://netplan.io/examples

I think that you have to specify a different mode parameter (you have 0).

mode (scalar)

Set the bonding mode used for the interfaces. The default is balance-rr (round robin). Possible values are balance-rr, active-backup, balance-xor, broadcast, 802.3ad, balance-tlb, and balance-alb.

  • Thanks, but it makes no differens. – HrzM Jun 27 at 0:01
  • @HrzM what did you change the mode to? netplan is VERY fussy about indentation, spacing, tabs, etc. Although I don't think it'll make any difference, try removing the blank lines that appear before bonds. Then sudo netplan --debug generate and sudo netplan apply and reboot. – heynnema Jun 27 at 0:06
  • @HrzM do you have anything in /etc/network/interfaces? – heynnema Jun 27 at 13:40
  • I changed it to balance-rr. /etc/network/interfaces is empty. – HrzM Jun 27 at 17:43
  • @HrzM I wonder if you've got the latest netplan installed. dpkg -l *netplan*. – heynnema Jun 27 at 17:54
0

Back up your netplan-config file first

Replace the contents with this:

network:
   bonds:
       bond0:
           addresses: [192.168.88.8/24]
           gateway4: 192.168.88.1
           nameservers:
              addresses: [127.0.0.1, 192.168.88.1]
           interfaces:
              - enp2s0
              - enp3s0
   ethernets:
       enp2s0:
         dhcp4:false
       enp3s0:
         dhcp4:false

Issue the following command to apply it:

sudo netplan apply

or you can just reboot

please make sure ethernets has the same indentation level as bonds

  • Thank you, but i can't apply that config. root@gemini:/etc/netplan# netplan apply /etc/netplan/01-netcfg.yaml:10:14: Error in network definition: bond0: interface 'enp3s0' is not defined - enp3s0 ^ – HrzM Jun 26 at 23:58
  • This is usually because of indentation not correct. I indented the interfaces now. Please try it and pay attention to indentation. – Raffa Jun 27 at 0:24
  • Still bond0: interface 'enp3s0' is not defined copy&paste and manuel typing. – HrzM Jun 27 at 17:41
  • Added interfaces definition. Now it should apply. Please try it. – Raffa Jun 28 at 0:47
  • root@gemini:/etc/netplan# netplan generate /etc/netplan/01-netcfg.yaml:10:17: Error in network definition: bond0: interface 'enp3s0' is not defined - enp3s0 ^ root@gemini:/etc/netplan# – HrzM Jul 10 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.