0

I use pass utility in Ubuntu to store my passwords. On my native machine, when I try to access a password using pass it pops up a window asking for the passphrase the first time and any subsequent time it remembers it. This is a all fine so far. The problem is when I ssh into my Ubuntu machine (let's say using putty), I can't access my passwords using pass. I think it's trying to open the passphrase window but it can't. How can I enter the passphrase manually or force it to ask me the passphrase in the command line?

PS. None of the suggested methods work for me. For example none of the solutions here work: Enter SSH passphrase once

EDIT: pass uses gnupg and based on this link, it seems it's really hard to work around gpg window pop up: https://lists.gnupg.org/pipermail/gnupg-users/2018-February/059914.html

This link suggests adding export GPG_TTY=$(tty) export PINENTRY_USER_DATA="USE_CURSES=1" to .bashrc but this doesn't help either: https://gpgtools.tenderapp.com/discussions/problems/50502-how-to-avoid-pinentry-pop-up-window-when-using-terminal

The solution here doesn't work either: https://dilawarnotes.wordpress.com/2013/02/13/disable-gpg-gui-asking-for-paraphrase/

0

I found an answer on StackOverflow that did the magic. Here's the link: https://stackoverflow.com/a/53641081/1708426

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.