2

How do I completely disable all power management settings in Ubuntu 18.04 LTS (non-GUI)? I don't want the system to sleep/hibernate/disable wifi and so on.

Thanks

  • 1
    I believe all you have to type in to disable the power management is xset -dpms and then to enable it is xset dpms. – Terrance Jun 26 '19 at 18:55
  • xset works on Ubuntu server (non-gui)? – zer02 Jun 26 '19 at 19:03
  • 1
    It should, it is a command line utility. – Terrance Jun 26 '19 at 19:08
  • Your mention of "wifi and so on" is putting me off: AIUI power management and "power saving" are different systems. If you want to turn off USB power saving (eg wifi problems) that's different to disabling hibernation, et al.. – pbhj Jun 27 '19 at 7:53
  • I mean all kind of power management and power saving options. USB power saving, WIFI power saving, Hibernation, Hard disk sleep and all of this. – zer02 Jun 27 '19 at 8:33
0

I came across this problem with the laptop ALWAYS going to sleep, in that the screen goes blank/black and I must reboot to wake it up.

I tried ... all of these Screen Going into SLEEP MODE, or BLACK, when NOT set to!

$ gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

$ gsettings set org.gnome.desktop.screensaver lock-enabled false

$ gsettings set org.gnome.desktop.lockdown disable-lock-screen true

• and a way to make this permanent, you need a gsettings override file... ‣ Open a new empty document in gedit, (or another text editor) on your host system.

STILL keeps going automatically to sleep!

OK so try this ... APM (Automatic Power Management) is ON IN THE BIOS or at a lower base level.

a strange solution That for now is working, is to edit grub with the APM=OFF parameter. To do this

Open the Grub file:

sudo gedit /etc/default/grub

add the apm=off to a line that will look like this:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=off apm=off"

Yours may be slightly different but add it to whatever is between the " " (quotes) a more typical is to put it after the standard "quiet splash'

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash (IN HERE)**"

and one must Update Grub, after saving this file, using terminal with the command:

sudo update-grub

and of course ... reboot

FEWWWW!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.