-1

I can't read Japanese but I buy a lot of Japanese games and apply fan-translations to them. Unfortunately a lot of such games require your system locale to be set to Japanese to even install/unpack let alone play. Back when I used windows I just set the locale to Japanese and there were no problems of note. However I'm not really sure how to do that in Ubuntu without breaking something and would prefer to ask for a safe method rather than try something random and end up with the whole system in Japanese or worse. From what I understand this happens because the game files themselves are still in Japanese the only thing that has been changed is the in game language. For example the file that contains equipment would be in japanese but the names of the equiment in game would be in english.To reitorate the locale itself has to be set to japanese just having it installed does nothing.

I followed the following instructions from this page

Changing settings permanently If you want more fine-grained control, you may manually change your system's locale entries by modifying the file /etc/default/locale (or the user-specific $HOME/.pam_environment, which can be set by gnome-language-selector as well).

For example on a German system, to prevent system messages from being translated, you may use:

LANG=de_DE.UTF-8 
LC_MESSAGES=POSIX 

Note: changes take effect only after a fresh login.

Older releases, at least before Lucid (when did this change?), required modifying the file /etc/environment.

As an alternative to editing these files by hand update-locale may be used (this applies to older releases as well, at least before Raring):

$ update-locale LANG=de_DE.UTF-8 LC_MESSAGES=POSIX

If none of the above worked for you there is an option to change the actual definition of a locale. You need to edit a file with your locale, for instance:

$ sudo nano /usr/share/i18n/locales/ru_RU

and change the definition that you need. and then recompile locale definition files by:

$ sudo locale-gen 

Read the man page for more information. I use Lubuntu 18.04

I used the update-locale method replacing de_DE.UTF-8 with ja_JP.UTF8 and ja_JP.UTF-8 but turning it back via the command didn't work.

I also edited /etc/default/locale via sudo gedit /etc/default/locale and sudo su gedit /etc/default/locale sudo su did not stick just plain sudo did but failed to change anything.

Trying sudo nano /usr/share/i18n/locales/ja_JP did what it was sopposed to but showed me a bunch of code I didn't understand so I just decided to exit before I broke something.

locale -a returns

C
C.UTF-8
POSIX
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IL
en_IL.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
ja_JP.utf8

locale returns

LANG=en_US.UTF-8
LANGUAGE=en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=POSIX
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

sudo gedit /etc/default/locale contains

#  File generated by update-locale
LANG="en_US.UTF-8"
LC_MESSAGES=POSIX
LANGUAGE="en"
LC_NUMERIC="ja_JP.UTF-8"
LC_TIME="ja_JP.UTF-8"
LC_MONETARY="ja_JP.UTF-8"
LC_PAPER="ja_JP.UTF-8"
LC_IDENTIFICATION="ja_JP.UTF-8"
LC_NAME="ja_JP.UTF-8"
LC_ADDRESS="ja_JP.UTF-8"
LC_TELEPHONE="ja_JP.UTF-8"
LC_MEASUREMENT="ja_JP.UTF-8"

when it is set to the first gnome selector image.

locale returns

LANG=ja_JP.UTF-8
LANGUAGE=ja:en
LC_CTYPE="ja_JP.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="ja_JP.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=POSIX
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

sudo gedit /etc/default/locale contains

#  File generated by update-locale
LANG="ja_JP.UTF-8"
LC_MESSAGES=POSIX
LANGUAGE="ja:en"
LC_NUMERIC="ja_JP.UTF-8"
LC_TIME="ja_JP.UTF-8"
LC_MONETARY="ja_JP.UTF-8"
LC_PAPER="ja_JP.UTF-8"
LC_IDENTIFICATION="ja_JP.UTF-8"
LC_NAME="ja_JP.UTF-8"
LC_ADDRESS="ja_JP.UTF-8"
LC_TELEPHONE="ja_JP.UTF-8"
LC_MEASUREMENT="ja_JP.UTF-8"

for the second gnome language selector image

locale returns

LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=POSIX
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

sudo gedit /etc/default/locale contains

#  File generated by update-locale
LANG="ja_JP.UTF-8"
LC_MESSAGES=POSIX
LANGUAGE="ja:en"
LC_NUMERIC="ja_JP.UTF-8"
LC_TIME="ja_JP.UTF-8"
LC_MONETARY="ja_JP.UTF-8"
LC_PAPER="ja_JP.UTF-8"
LC_IDENTIFICATION="ja_JP.UTF-8"
LC_NAME="ja_JP.UTF-8"
LC_ADDRESS="ja_JP.UTF-8"
LC_TELEPHONE="ja_JP.UTF-8"
LC_MEASUREMENT="ja_JP.UTF-8"

for the third gnome language selector image which is really weird because the menus are in english but the game still won't work.

locale returns

LANG=ja_JP.UTF-8
LANGUAGE=ja:en
LC_CTYPE="ja_JP.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="ja_JP.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=POSIX
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

sudo gedit /etc/default/locale contains

#  File generated by update-locale
LANG="ja_JP.UTF-8"
LC_MESSAGES=POSIX
LANGUAGE="ja:en"
LC_NUMERIC="ja_JP.UTF-8"
LC_TIME="ja_JP.UTF-8"
LC_MONETARY="ja_JP.UTF-8"
LC_PAPER="ja_JP.UTF-8"
LC_IDENTIFICATION="ja_JP.UTF-8"
LC_NAME="ja_JP.UTF-8"
LC_ADDRESS="ja_JP.UTF-8"
LC_TELEPHONE="ja_JP.UTF-8"
LC_MEASUREMENT="ja_JP.UTF-8"

when it is set to the fourth gnome language selector screenie

rebooting to get more stuff Note to Duplicate voters: Wine was just an example because I have the most experience with Windows games. I decided to try it anyway, but the download page is dead.

enter image description here

I get the following message when attempting to run winelocale through python I might be doing it wrong though.

python2 /home/ys/windows-games/tool/winelocale-master/current/winelocale.py
    Traceback (most recent call last):
      File "/home/ys/windows-games/tool/winelocale-master/current/winelocale.py", line 50, in <module>
        from gnome import url_show        # handle URL clicks in GUI
    ImportError: No module named gnome

I also tried

python /home/ys/windows-games/tool/winelocale-master/current/winelocale.py
Traceback (most recent call last):
  File "/home/ys/windows-games/tool/winelocale-master/current/winelocale.py", line 50, in <module>
    from gnome import url_show        # handle URL clicks in GUI
ImportError: No module named gnome

and

python3 /home/ys/windows-games/tool/winelocale-master/current/winelocale.py
  File "/home/ys/windows-games/tool/winelocale-master/current/winelocale.py", line 83
    print "Unable to find a language file for " + os.environ["LANG"][0:5] + ", using en_US"
                                              ^
SyntaxError: Missing parentheses in call to 'print'. Did you mean print("Unable to find a language file for " + os.environ["LANG"][0:5] + ", using en_US")?

and

python winelocale.py
python: can't open file 'winelocale.py': [Errno 2] No such file or directory

and

python2 winelocale.py
python2: can't open file 'winelocale.py': [Errno 2] No such file or directory

and

python3 winelocale.py
python3: can't open file 'winelocale.py': [Errno 2] No such file or directory

Just in case

sorry about the extra ands wasn't sure how to seperate bricks of code otherwise

here is what it looks like when I have it set to english the game won't launch or unpack correctly when it's in this state.

enter image description here

here's what it looks like in japanese the game can launch and unpack without issue in this state

enter image description here

settings it to

enter image description here

and

enter image description here

also does not work

I launch it via the following command

gnome-language-selector

and apply system wide

  • 2
    Possible duplicate of How to change locale for Wine only? – user68186 Jun 26 at 17:06
  • I don't know where to get winelocale .debs. But github.com/Tatsh/winelocale may help. winelocale is a Python program, so no compilation is needed. You may be able to download and run this, passing its name as an argument to the python2 command. I think this question is a duplicate of that one but I'm reluctant to vote to close until the answer is known to work for you. If someone--you?--figures it out, they could add another answer there or maybe even edit the existing one. – Eliah Kagan Jul 3 at 0:17
  • @EliahKagan I'll try that out there was a lot of results for it on the web but I don't want to go downloading random stuff off the internet because that's an easy way to invite viruses. If it works it'll solve the primary problem at least. I'll do it tomorrow since it's late and I don't want to mess around with my pc when I'm half asleep. – Mage in the Barrel Jul 3 at 0:42
  • As you've added al that to the question, no need to leave it in the answer (not upvoted anyway, so deleted) – Fabby Jul 6 at 14:22
  • is there any way to put content in a dropdown type thing like some forums spoiler function my post is getting very long with all the information I've added. – Mage in the Barrel Jul 6 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.