3

I have a kernel bug that makes my SSD go into read-only mode. To fix this I have to reboot the system, do fsck /dev/nvme0n1p2, and then reboot again to make everything work.

Instead of doing the reboot, I tried to just do

sudo fsck /dev/nvme0n1p2

but how can I mount the nvme0n1p2 disk without rebooting? I want to work on my machine without needing to reboot.

I tried:

lz@blade:~$ sudo mount /dev/nvme0n1p2
mount: /: /dev/nvme0n1p2 already mounted on /.

So I tried:

lz@blade:~$ sudo umount /dev/nvme0n1p2
lz@blade:~$ sudo mount /dev/nvme0n1p2
mount: /: /dev/nvme0n1p2 already mounted on /.

Can somebody help me?

4
  • 2
    Also, disks go read-only for a reason. You should definitely look into why that's happening. syslog is your friend. Jun 27, 2019 at 3:55
  • 1
    Did you tried blockdev --setrw? Jun 27, 2019 at 3:59
  • Are you sure it is not the SSD going into the "I am dying" mode, making it read only so you can rescue stuff?
    – Dr_Bunsen
    Jun 27, 2019 at 14:53
  • @Dr_Bunsen I tried another brand new SSD and the same problem happens, and also other people have this problem Jun 27, 2019 at 21:21

2 Answers 2

3
+50

Can you please try this:

mount -o remount,rw /dev/nvme0n1p2

It works fine for me.

If you find anything please let me know.

-Karmdip Joshi

1
  • 2
    sudo mount -o remount,rw /dev/nvme0n1p2 mount: /: cannot remount /dev/nvme0n1p2 read-write, is write-protected. Jul 2, 2019 at 3:53
3

From Linux, how to change HDD state from ReadOnly after temporarly crash? the accepted answer (with 12 upvotes, at the time of this writing) states:

try with blockdev --setrw or hdparm -r 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.